aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-04 11:57:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-04 13:23:05 +0000
commit5e39a11f17159b3b3bef21d75c63caa85dfc089e (patch)
treeaf9165d0e1223c9c42217000dfdd987551fe2ad1 /main
parent8b8db78874114b291db532e9ebd21a4910f8574b (diff)
downloadaports-5e39a11f17159b3b3bef21d75c63caa85dfc089e.tar.bz2
aports-5e39a11f17159b3b3bef21d75c63caa85dfc089e.tar.xz
main/xf86-video-vesa: rebuild against xorg-server-1.19
Diffstat (limited to 'main')
-rw-r--r--main/xf86-video-vesa/APKBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/main/xf86-video-vesa/APKBUILD b/main/xf86-video-vesa/APKBUILD
index a0e84b2160..23a7c8fb01 100644
--- a/main/xf86-video-vesa/APKBUILD
+++ b/main/xf86-video-vesa/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=1
pkgdesc="X.org vesa video driver"
url="http://xorg.freedesktop.org/"
arch="all"
-license="custom"
+license="MIT"
subpackages="$pkgname-doc"
depends=
makedepends="xorg-server-dev libxi-dev fontsproto randrproto
@@ -14,18 +14,9 @@ makedepends="xorg-server-dev libxi-dev fontsproto randrproto
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
@@ -36,7 +27,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}