aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-29 20:15:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-29 20:15:23 -0300
commit79d4bf70deb43c3bd6df616bd2aeb4b917afd762 (patch)
treed389debb33b345e8f6a6e5e48881152ccd4467b6 /main
parent8ec3ec758802888ca1fc251333ae324d1e558dcb (diff)
downloadaports-79d4bf70deb43c3bd6df616bd2aeb4b917afd762.tar.bz2
aports-79d4bf70deb43c3bd6df616bd2aeb4b917afd762.tar.xz
main/libisoburn: move from community
Diffstat (limited to 'main')
-rw-r--r--main/libisoburn/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/main/libisoburn/APKBUILD b/main/libisoburn/APKBUILD
new file mode 100644
index 0000000000..ecb6afc97b
--- /dev/null
+++ b/main/libisoburn/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libisoburn
+pkgver=1.5.2
+pkgrel=0
+pkgdesc="Library to enable creation and expansion of ISO-9660 filesystems"
+url="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="libburn-dev libisofs-dev acl-dev zlib-dev
+ libedit-dev"
+subpackages="$pkgname-dev $pkgname-doc xorriso:_xorriso"
+source="http://files.libburnia-project.org/releases/libisoburn-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/bin/xorriso-tcltk
+ ln -s xorriso "$pkgdir"/usr/bin/mkisofs
+}
+
+_xorriso() {
+ pkgdesc="ISO-9660 and Rock Ridge image manipulation tool"
+ replaces="cdrkit"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="b481aa5ff20bb35ab0ab19f3f4f3ebc4f2baa8366a14a5afe4f262788441679b6501e140e182f4e80045c747f1cf48db40832d8d5cd064e58a02de2882536897 libisoburn-1.5.2.tar.gz"