aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-22 06:05:36 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-24 13:12:23 +0100
commit7b3295e8d6df72cdffb13542a805420618862b21 (patch)
treecc282d4def55a51b37a8a55b6f123a86d6b9a063 /main
parent0ae4560ab453ded738909c828f8ebd008026aa3c (diff)
downloadaports-7b3295e8d6df72cdffb13542a805420618862b21.tar.bz2
aports-7b3295e8d6df72cdffb13542a805420618862b21.tar.xz
main/iperf3: upgrade to 3.5
Diffstat (limited to 'main')
-rw-r--r--main/iperf3/APKBUILD8
-rw-r--r--main/iperf3/build-fixes.patch14
-rw-r--r--main/iperf3/remove-pg-flags.patch13
3 files changed, 17 insertions, 18 deletions
diff --git a/main/iperf3/APKBUILD b/main/iperf3/APKBUILD
index 87b0a2a4ba..30e5b0e1dd 100644
--- a/main/iperf3/APKBUILD
+++ b/main/iperf3/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iperf3
_pkgname=iperf
-pkgver=3.4
+pkgver=3.5
pkgrel=0
pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
url="https://github.com/esnet/iperf"
@@ -49,8 +49,8 @@ package() {
"$pkgdir"/etc/conf.d/$_pkgname
}
-sha512sums="dacc1c02515d42276f810609eeeeb95c393222695e541917928f5373e4bc7033da93038a6ffa3898d00e39a47c6e4bdf02d08e39f429e9032f25912d723c71de iperf3-3.4.tar.gz
+sha512sums="f1823b5cd23b344b772a37f485e458d6b3703c11892ea4fa2abca61f474eed6229b3cb75db78adedf87092431d11c3174bfbd92833fc56dedab64953f50ac6a4 iperf3-3.5.tar.gz
339fb04b41cce11e8ea8694d95c13af9c88e0d1143356d913ec810c9b11efa27212d585b5dcc49cc2eb860a6d8bc557092c8659d7d5cfe532c5afdb36f8eedf8 iperf.initd
fb5e155fff568a72488cc1511d30358835a48bcce309f8f46d040160932b4a4ccb85040c27c60dee477900a25bd34c50eac21d1d0bea984b40faa401be2ba7e8 iperf.confd
-e544ae5545f6b8ff071a1344068f9ed2bec051eb82a3b53cfccda767ea915ecf2aff5f2bf91135cba62afdb1fd421298518fa0b08339c869a4d381b1e1d396dd build-fixes.patch
-81808862eecacdd7be658daa094385d7a57594281992b6b9b842cee676137d6990dce592b25e5db9fb80ea86628286ff7d234787d2939ef1f99820a361e1f3c6 remove-pg-flags.patch"
+126043503eebf84bccf26758f18715eaf81131e2fc9ef1fe829e55acb2f14e97db18e9b890b8bf13c230ac80c7537615272af4e072808e25bde8ddd6f326f198 build-fixes.patch
+ed0fb3a3af0dae3e9f58ff6643cb15defdd31f65cf966a6013fdf2a7fd67a7f8ef522a7c8f3269bd43d5ca991a86d758526c384ebc0984b1403bb24f61a1779b remove-pg-flags.patch"
diff --git a/main/iperf3/build-fixes.patch b/main/iperf3/build-fixes.patch
index e361a86507..b797e70ea5 100644
--- a/main/iperf3/build-fixes.patch
+++ b/main/iperf3/build-fixes.patch
@@ -1,7 +1,6 @@
-diff -upr iperf-3.1.5.orig/src/t_timer.c iperf-3.1.5/src/t_timer.c
---- iperf-3.1.5.orig/src/t_timer.c 2017-01-17 12:19:14.044458009 +0100
-+++ iperf-3.1.5/src/t_timer.c 2017-01-17 12:19:34.674090042 +0100
-@@ -28,6 +28,7 @@
+--- a/src/t_timer.c
++++ b/src/t_timer.c
+@@ -33,6 +33,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <sys/time.h>
@@ -9,9 +8,8 @@ diff -upr iperf-3.1.5.orig/src/t_timer.c iperf-3.1.5/src/t_timer.c
#include "timer.h"
-diff -upr iperf-3.1.5.orig/src/t_uuid.c iperf-3.1.5/src/t_uuid.c
---- iperf-3.1.5.orig/src/t_uuid.c 2017-01-17 12:20:38.013934038 +0100
-+++ iperf-3.1.5/src/t_uuid.c 2017-01-17 12:20:57.200620745 +0100
+--- a/src/t_uuid.c
++++ b/src/t_uuid.c
@@ -28,6 +28,7 @@
#include <stdlib.h>
#include <string.h>
@@ -19,4 +17,4 @@ diff -upr iperf-3.1.5.orig/src/t_uuid.c iperf-3.1.5/src/t_uuid.c
+#include <sys/types.h>
#include "iperf_util.h"
-
+
diff --git a/main/iperf3/remove-pg-flags.patch b/main/iperf3/remove-pg-flags.patch
index 4d6482d3d8..1ed47eebf5 100644
--- a/main/iperf3/remove-pg-flags.patch
+++ b/main/iperf3/remove-pg-flags.patch
@@ -1,6 +1,6 @@
---- ./src/Makefile.am.orig
-+++ ./src/Makefile.am
-@@ -49,9 +49,9 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -50,9 +50,9 @@
iperf3_profile_SOURCES = main.c \
$(libiperf_la_SOURCES)
@@ -12,9 +12,10 @@
# Specify the sources and various flags for the test cases
t_timer_SOURCES = t_timer.c
---- ./src/Makefile.in.orig
-+++ ./src/Makefile.in
-@@ -610,9 +610,9 @@
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -643,9 +643,9 @@
iperf3_profile_SOURCES = main.c \
$(libiperf_la_SOURCES)