aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-05-01 01:26:18 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-06 13:58:50 +0000
commitc97bcbcab4c58d9d8538ce2c764888c2e0913fe5 (patch)
tree029084ca8e6c40d4dbcf532831a52acfa28dc225 /main
parentaac194968015e50383144a04b526574a5e0c315d (diff)
downloadaports-c97bcbcab4c58d9d8538ce2c764888c2e0913fe5.tar.bz2
aports-c97bcbcab4c58d9d8538ce2c764888c2e0913fe5.tar.xz
main/kamailio: upgrade to 5.3.3
Diffstat (limited to 'main')
-rw-r--r--main/kamailio/0001-mohqueue.patch17
-rw-r--r--main/kamailio/0004-src_core_tcp_read_c.patch20
-rw-r--r--main/kamailio/APKBUILD26
-rw-r--r--main/kamailio/dont-force-mips-revision.patch30
4 files changed, 8 insertions, 85 deletions
diff --git a/main/kamailio/0001-mohqueue.patch b/main/kamailio/0001-mohqueue.patch
deleted file mode 100644
index 72ca36b12b..0000000000
--- a/main/kamailio/0001-mohqueue.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/modules/mohqueue/mohq_funcs.c
-+++ b/src/modules/mohqueue/mohq_funcs.c
-@@ -1405,9 +1405,12 @@
-
- {
- call_lst *pcall = (call_lst *)*pcbp->param;
-+if (pcall->call_state >= CLSTA_INQUEUE)
-+ { return; }
-+LM_ERR ("invite_cb: INVITE failed for call (%s), code=%x, callstate=%x!\n",
-+ pcall->call_from, ntype, pcall->call_state);
- if (ntype == TMCB_DESTROY)
- { pcall->call_hash = pcall->call_label = 0; }
--LM_ERR ("invite_cb: INVITE failed for call (%s)!\n", pcall->call_from);
- delete_call (pcall);
- return;
- }
-
diff --git a/main/kamailio/0004-src_core_tcp_read_c.patch b/main/kamailio/0004-src_core_tcp_read_c.patch
deleted file mode 100644
index 08308f77b1..0000000000
--- a/main/kamailio/0004-src_core_tcp_read_c.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-$OpenBSD: patch-src_core_tcp_read_c,v 1.1 2017/07/03 22:14:20 sthen Exp $
-
-Index: a/src/core/tcp_read.c
---- a/src/core/tcp_read.c.orig
-+++ a/src/core/tcp_read.c
-@@ -1497,6 +1497,14 @@ void release_tcpconn(struct tcp_connection* c, long st
- ip_addr2a(&c->rcv.src_ip), c->rcv.src_port,
- ip_addr2a(&c->rcv.dst_ip), c->rcv.dst_port);
- LM_DBG("extra_data %p\n", c->extra_data);
-+
-+ /* experimental fix tls crash with libressl */
-+ /* add cleanup SSL structure in child process, in parent process SSL structure is empty */
-+ if ((c->type==PROTO_TLS || c->type==PROTO_WSS) && (c->extra_data) && c->fd != -1) {
-+ tls_close(c, c->fd);
-+ tls_tcpconn_clean(c);
-+ }
-+
- /* release req & signal the parent */
- c->reader_pid=0; /* reset it */
- if (c->fd!=-1){
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index 272126ddd6..bfe894451a 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -4,8 +4,8 @@
# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
pkgname=kamailio
-pkgver=5.2.5
-pkgrel=3
+pkgver=5.3.3
+pkgrel=0
# If building from a git snapshot, specify the gitcommit
# If building a proper release, leave gitcommit blank
@@ -17,7 +17,7 @@ pkgrel=3
[ -z "$_gitcommit" ] && _gitcommit="$pkgver"
pkgdesc="Open Source SIP Server"
-url="http://www.kamailio.org/"
+url="https://www.kamailio.org/"
arch="all"
pkgusers="kamailio"
pkggroups="kamailio"
@@ -31,6 +31,9 @@ makedepends="bison db-dev flex freeradius-client-dev expat-dev
net-snmp-dev libuuid libev-dev jansson-dev json-c-dev libevent-dev
linux-headers libmemcached-dev rabbitmq-c-dev hiredis-dev
ruby-dev libmaxminddb-dev libunistring-dev"
+source="kamailio-${pkgver}$_suffix.tar.gz::https://github.com/kamailio/kamailio/archive/$_gitcommit.tar.gz
+ kamailio.initd
+ "
install="$pkgname.pre-install $pkgname.pre-upgrade"
@@ -255,13 +258,6 @@ for _i in db postgres sqlite dbtext mysql \
eval "_modules=\"\$_modules \$_mod_list_$_i\""
done
-source="kamailio-${pkgver}$_suffix.tar.gz::https://github.com/kamailio/kamailio/archive/$_gitcommit.tar.gz
- 0001-mohqueue.patch
- 0004-src_core_tcp_read_c.patch
- dont-force-mips-revision.patch
- kamailio.initd
- "
-
snapshot() {
if [ ! -f "$SRCDEST"/$pkgname-${pkgver}$_suffix.tar.gz ]; then
wget -O "$SRCDEST"/$pkgname-${pkgver}$_suffix.tar.gz https://github.com/kamailio/$pkgname/archive/$_gitcommit.tar.gz
@@ -295,7 +291,7 @@ build() {
}
package() {
- make FREERADIUS=1 -j1 install
+ make FREERADIUS=1 install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -d -o kamailio "$pkgdir"/var/run/kamailio
@@ -315,7 +311,6 @@ _generic_pkg() {
_mv_mod $2
}
-
_db_driver() {
pkgdesc="Database drivers for $1"
depends="$pkgname $pkgname-db"
@@ -328,7 +323,6 @@ _db_driver() {
"$subpkgdir"/usr/lib/kamailio/kamctl/
}
-
db() {
_generic_pkg "modules using a database backend" "$_mod_list_db"
}
@@ -489,7 +483,6 @@ jsdt() {
"$_mod_list_jsdt"
}
-
redis() {
_generic_pkg "Redis NoSQL support" \
"$_mod_list_redis"
@@ -545,8 +538,5 @@ sipdump() {
"$_mod_list_sipdump"
}
-sha512sums="045f52f633897fdfce8afe508bf2f803f79a2b7d16be129314464c0da7a124fd64d9de8783b11b184324775bebf9d9aa82eb76a9e9397b8d6fd2d8d3470b03e8 kamailio-5.2.5.tar.gz
-bbb00a3b680d2805aebf412a7cd77d5ac16e5edb45077516635101f78782dcaa779f84a3678fdd820fa7d7f021ae89271811b2e344092a8f5b7fe6eeee4c2599 0001-mohqueue.patch
-af8362201957eae6b66baf7368c9ca884024209a396d77c5c52180c9aabe13772e9c6513e59721d39503e5bb7a8c1030f5c10301ea9055bddafb7f01ee2f3076 0004-src_core_tcp_read_c.patch
-100a40ec63eaf62f8ac794f1bb17e8109030413617e61a7d2f55a8c8efbe26c1f0f611e6d99548638001f1af678fb7129a98db175eb02190c85d31f60af52202 dont-force-mips-revision.patch
+sha512sums="7f4bc0c6a189c5cd5f43af59a9d5babd66e2de0c30100ced834295fcf4dd3ddbf998c9f772e3da94d070bb0a7f30ae67d264bb84cc42788a047867d5cf709d13 kamailio-5.3.3.tar.gz
0c87bfb78481568c03e603049eb8597a90d24ae2941fc81694181b2326fa9db89fbddaaa3cf08c7bc2f5fa0e7ffac4cf4e2d010d08c4faa6cf6df98593432539 kamailio.initd"
diff --git a/main/kamailio/dont-force-mips-revision.patch b/main/kamailio/dont-force-mips-revision.patch
deleted file mode 100644
index 154772304e..0000000000
--- a/main/kamailio/dont-force-mips-revision.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/Makefile.defs
-+++ b/src/Makefile.defs
-@@ -321,7 +321,8 @@
-
- mips_macros= __mips__ __mips _MIPS_ARCH_MIPS1
- mips2_macros= _MIPS_ISA_MIPS2 _MIPS_ISA_MIPS3 _MIPS_ISA_MIPS4 \
-- _MIPS_ARCH_MIPS2 _MIPS_ARCH_MIPS3 _MIPS_ARCH_MIPS4
-+ _MIPS_ARCH_MIPS2 _MIPS_ARCH_MIPS3 _MIPS_ARCH_MIPS4 \
-+ _MIPS_ISA_MIPS32
- mips64_macros= _MIPS_ISA_MIPS64 _MIPS_ARCH_MIPS64
-
- alpha_macros= __alpha__ __alpha _M_ALPHA_
-@@ -1364,7 +1365,7 @@
- ifeq ($(CC_NAME), gcc)
- C_DEFS+=-DCC_GCC_LIKE_ASM
- #common stuff
-- CFLAGS= -mips2 $(CC_OPT) -funroll-loops $(PROFILE)
-+ CFLAGS= $(CC_OPT) -funroll-loops $(PROFILE)
- #if gcc 8.0+, 7.0+, 6.0+, 5.0+, 4.5+ or 4.2+
- ifeq (,$(strip $(filter-out 4.2+ 4.5+ 5.0+ 6.0+ 7.0+ 8.0+,$(CC_SHORTVER))))
- CFLAGS+=-ftree-vectorize -fno-strict-overflow
-@@ -1410,7 +1411,7 @@
- ifeq ($(CC_NAME), gcc)
- C_DEFS+=-DCC_GCC_LIKE_ASM
- #common stuff
-- CFLAGS= -mips64 $(CC_OPT) -funroll-loops $(PROFILE)
-+ CFLAGS= $(CC_OPT) -funroll-loops $(PROFILE)
- #if gcc 8.0+, 7.0+, 6.0+, 5.0+, 4.5+ or 4.2+
- ifeq (,$(strip $(filter-out 4.2+ 4.5+ 5.0+ 6.0+ 7.0+ 8.0+,$(CC_SHORTVER))))
- CFLAGS+=-ftree-vectorize -fno-strict-overflow