aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-23 14:49:19 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-27 06:23:05 +0000
commitf5c4b298918ba1d5ff85861cdeed9eff2cbcd5b9 (patch)
tree19e3047a9452bbbe6128e68e0dd54290e77abd65 /scripts
parentfb8794efbe6d82492a0adaec70c880e10c1e67f0 (diff)
downloadaports-f5c4b298918ba1d5ff85861cdeed9eff2cbcd5b9.tar.bz2
aports-f5c4b298918ba1d5ff85861cdeed9eff2cbcd5b9.tar.xz
community/go: cross-build support
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/bootstrap.sh6
1 files changed, 5 insertions, 1 deletions
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index a9fd7547b9..de2cf7e4ed 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -20,7 +20,10 @@ CBUILDROOT="$(CTARGET=$TARGET_ARCH . /usr/share/abuild/functions.sh ; echo $CBUI
[ -e "$APORTS/main/build-base" ] || die "Unable to deduce aports base checkout"
apkbuildname() {
- echo $APORTS/main/$1/APKBUILD
+ local repo="${1%%/*}"
+ local pkg="${1##*/}"
+ [ "$repo" = "$1" ] && repo="main"
+ echo $APORTS/$repo/$pkg/APKBUILD
}
msg() {
@@ -100,6 +103,7 @@ for PKG in fortify-headers linux-headers musl libc-dev pkgconf zlib \
attr libcap patch sudo acl fakeroot tar \
pax-utils abuild openssh \
ncurses util-linux lvm2 popt xz cryptsetup kmod lddtree mkinitfs \
+ community/go \
$KERNEL_PKG ; do
CHOST=$TARGET_ARCH BOOTSTRAP=bootimage APKBUILD=$(apkbuildname $PKG) abuild -r