aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-05-12 19:42:32 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-05-12 19:45:36 +0300
commit1e36692a8aee88564b19e6855febd91b4feea5eb (patch)
tree660ef9f645c7462ce176a0c45be3844c0e894f26 /src/Makefile
parent73a03c2e40b9c429342729d009801751bd0812da (diff)
downloadaports-1e36692a8aee88564b19e6855febd91b4feea5eb.tar.bz2
aports-1e36692a8aee88564b19e6855febd91b4feea5eb.tar.xz
finally fix building PIE binaries
the dynamic applet registration never worked with PIE, and as a temporary hack -nopie was added to default link flags in 2008. this commit reworks the applet registration mechanism to something that is compatible with PIE, and removes the hack. finally!
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile b/src/Makefile
index 4487007f4a..8fdaf4b4e5 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -62,8 +62,8 @@ progs-$(STATIC) += apk.static
apk.static-objs := $(filter-out apk.o,$(apk-objs)) apk-static.o
LDFLAGS_apk.static := -static
LIBS_apk.static := -Wl,--as-needed -ldl -Wl,--no-as-needed
-LDFLAGS_apk += -nopie -L$(obj)
-LDFLAGS_apk-test += -nopie -L$(obj)
+LDFLAGS_apk += -L$(obj)
+LDFLAGS_apk-test += -L$(obj)
CFLAGS_ALL += $(shell $(PKG_CONFIG) --cflags $(PKGDEPS))
LIBS := -Wl,--as-needed \