aboutsummaryrefslogtreecommitdiffstats
path: root/testing/6cord/APKBUILD
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2020-02-22 01:42:27 +0700
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 00:20:18 -0300
commitbd4799774beb48d5c1f13acd508103f341f79193 (patch)
tree9630ca21c4c3ee0f07d9dda9d94d6cbb92b0ce58 /testing/6cord/APKBUILD
parenteb2bacf5e662227d56e4fb2f884ffbd7b214c86e (diff)
downloadaports-bd4799774beb48d5c1f13acd508103f341f79193.tar.bz2
aports-bd4799774beb48d5c1f13acd508103f341f79193.tar.xz
testing/6cord: new aport
Signed-off-by: Danct12 <danct12@disroot.org>
Diffstat (limited to 'testing/6cord/APKBUILD')
-rw-r--r--testing/6cord/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/6cord/APKBUILD b/testing/6cord/APKBUILD
new file mode 100644
index 0000000000..390fd18934
--- /dev/null
+++ b/testing/6cord/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname="6cord"
+pkgver="9.6"
+pkgrel=0
+pkgdesc="Discord TUI + SIXEL client"
+url="https://gitlab.com/diamondburned/6cord"
+arch="all"
+license="MPL-2.0"
+makedepends="go"
+install="$pkgname.post-install"
+source="https://gitlab.com/diamondburned/6cord/-/archive/stable-$pkgver/6cord-stable-$pkgver.tar.bz2"
+options="!check" # no testsuite
+builddir="$srcdir/6cord-stable-$pkgver"
+
+build() {
+ go build -o bin/6cord
+}
+
+package() {
+ install -Dm755 "$builddir"/bin/6cord \
+ "$pkgdir"/usr/bin/6cord
+ install -Dm755 "$builddir"/6cord.toml \
+ "$pkgdir"/usr/share/$pkgname/6cord.toml
+}
+
+sha512sums="e41de615e6ed95ac269725ae3155b15218d627821977f0e2e98a075a7b0e83028fdc94d200bf86bdc8271aede43c775dddf493e48ace3f52cd297d3e09cdb2db 6cord-stable-9.6.tar.bz2"