aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-06 20:52:28 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-06 20:52:28 +0200
commit27b065aee488d02c98b91a49acad8c78ebe5bef9 (patch)
treeb55c96275f93626ce9e57768f267c75e21580d71 /testing
parent941eb5e4013145d1a7cd96913b7a41a76c0eef85 (diff)
downloadaports-27b065aee488d02c98b91a49acad8c78ebe5bef9.tar.bz2
aports-27b065aee488d02c98b91a49acad8c78ebe5bef9.tar.xz
Revert "testing/gogs: upgrade to 0.9.13"
This reverts commit 2867d304f9c04812d4a029d518159411ecf944c2. Fails on build server and blocks other packages.
Diffstat (limited to 'testing')
-rw-r--r--testing/gogs/APKBUILD48
-rw-r--r--testing/gogs/list.tmpl.patch11
2 files changed, 33 insertions, 26 deletions
diff --git a/testing/gogs/APKBUILD b/testing/gogs/APKBUILD
index 5aa717d891..f6d1ed805c 100644
--- a/testing/gogs/APKBUILD
+++ b/testing/gogs/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: 7heo <7heo@mail.com>
pkgname=gogs
-pkgver=0.9.13
-pkgrel=0
+pkgver=0.6.1
+pkgrel=5
pkgdesc="A self-hosted Git service written in Go"
url="http://gogs.io/"
arch="all"
license="MIT"
depends="git"
-makedepends="go-tools perl libcap"
+makedepends="go-tools perl"
install="$pkgname.pre-install"
pkgusers="gogs"
pkggroups="www-data"
@@ -16,28 +16,26 @@ options="!strip"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- $pkgname.ini"
+ $pkgname.ini
+ list.tmpl.patch"
builddir="$srcdir/src/github.com/gogits"
_disturl="dev.alpinelinux.org:/archive/$pkgname/"
_gourl="github.com/gogits/gogs"
snapshot() {
- abuild clean && abuild deps
+ abuild clean
export GOPATH="$srcdir"
- msg "Checking out v${pkgver} tag"
- # go get will not checkout a specific tag
- # so we run our own git checkout branch
- git clone --quiet --branch v${pkgver} \
- https://$_gourl $builddir || return 1
+ mkdir -p $builddir
cd $builddir
- # fetch deps
- go get -v -d -tags "sqlite redis memcache" || return 1
+ msg "Checking out v${pkgver} tag"
+ git clone -q --branch v${pkgver} https://$_gourl || return 1
+ cd gogs
+ go get -v -u -d -tags "sqlite redis memcache" || return 1
+ git submodule update --init || return 1
cd "$srcdir"
tar zcf $pkgname-$pkgver.tar.gz src || return 1
- rsync --progress -La $pkgname-$pkgver.tar.gz \
- $_disturl || return 1
- cd $startdir && abuild undeps
+ rsync --progress -La $pkgname-$pkgver.tar.gz $_disturl || return 1
}
build() {
@@ -61,11 +59,6 @@ package() {
"$pkgdir"/var/log/$pkgname || return 1
install -Dm 0755 $pkgname/$pkgname \
"$pkgdir"/usr/bin/$pkgname || return 1
- # allow to bind to port 80
- setcap cap_net_bind_service=+ep \
- "$pkgdir"/usr/bin/$pkgname || return 1
- install -d -o gogs -g www-data \
- "$pkgdir"/etc/$pkgname/conf || return 1
install -Dm 0664 -o gogs -g www-data "$srcdir"/${pkgname}.ini \
"$pkgdir"/etc/$pkgname/conf/app.ini || return 1
mv $pkgname/public "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
@@ -76,15 +69,18 @@ package() {
"$pkgdir"/etc/conf.d/$pkgname || return 1
}
-md5sums="0d609a490ea2b225cfc9153b47d7392a gogs-0.9.13.tar.gz
+md5sums="a363596502666e7318a776618f525d80 gogs-0.6.1.tar.gz
91cd8b6b27509beecb53594463315f43 gogs.initd
6b3f501f9c37b5032cab8b49b5621fc4 gogs.confd
-82edfdabfdf0ac64dc545036ca499465 gogs.ini"
-sha256sums="6c2f79eecfd89197ad6359f389e9de39cd4f7211566ef6488437e7f5dc94b31d gogs-0.9.13.tar.gz
+82edfdabfdf0ac64dc545036ca499465 gogs.ini
+57e21516f0266322097282fcaeafde30 list.tmpl.patch"
+sha256sums="1da9743b4551e7552c84af56a390e55cbab37ca3407ba1b52fc69e546fc4473b gogs-0.6.1.tar.gz
23a9bfcf7d1fd7cb5b7bf13ab0b0f412c29c1ebdd62fc02c78dd885cbe5d703d gogs.initd
a1c584dbc2d44694ffcf87ecafdf6a43ae81370175ca9cc6e6ff7623b8b05254 gogs.confd
-ead0082c56e8e8f9e9ba7f4c206c2a18bb732726137b71e05d83347638562530 gogs.ini"
-sha512sums="88a6889ada2e42cc5b6e362a868230f3ce9f814cc6914cfe59abd5a320b0cb908e20d7f274c2f61f17b9a6d5e385633ffeb9697274ea5406fad3c0522dab9b49 gogs-0.9.13.tar.gz
+ead0082c56e8e8f9e9ba7f4c206c2a18bb732726137b71e05d83347638562530 gogs.ini
+471d404b1766b9267767e46c0207d7a11346e421ee227ced981e37abd79940a4 list.tmpl.patch"
+sha512sums="17e39b637366c5eae9ce29e75a703c8ef7d1b4e42be0299f2c440aa5e0dd5e0caf71e07535675fb7cd5fe19a13db6535e9e88863bbb92c974ee9d21f1dff4a51 gogs-0.6.1.tar.gz
be5a9ef2cae1ee2e8106feb6a997ae06519af91fe57f746d20996e79c332c93bb43fc53f79ff4e8ce13222afc6f3dc7bc5cbb758ef201b03e49d809c87c8c4c7 gogs.initd
52ce41c05c263b790221a04d13d2eb9bba689e4bd72daf5b6af31416e80a485a46bae19e18581d7bde879307283847e6486686a2fe4140fe38ebb6f315e11a86 gogs.confd
-4c2b398cf93ebb8b743b9e7ec1b075706427081036effb53fa90729e70fbc3eb92f2f853278b887ca79dc35cd55a64e1bff4d18e1ad246beab2a723aa9cd71ba gogs.ini"
+4c2b398cf93ebb8b743b9e7ec1b075706427081036effb53fa90729e70fbc3eb92f2f853278b887ca79dc35cd55a64e1bff4d18e1ad246beab2a723aa9cd71ba gogs.ini
+70ce5ebf453f476ec83480715ae48ce801ddfc42f82b3c45081c650073a1f226e4290f20ba161646f3cce6bfee84a247c544edde299cddc779437ffe8d1f34ae list.tmpl.patch"
diff --git a/testing/gogs/list.tmpl.patch b/testing/gogs/list.tmpl.patch
new file mode 100644
index 0000000000..7bab1cf9e5
--- /dev/null
+++ b/testing/gogs/list.tmpl.patch
@@ -0,0 +1,11 @@
+--- a/gogs/templates/repo/issue/list.tmpl
++++ b/gogs/templates/repo/issue/list.tmpl
+@@ -7,7 +7,7 @@
+ <div class="col-md-3 filters">
+ <div class="filter-list">
+ <ul class="list-unstyled">
+- <li><a href="{{.RepoLink}}/issues?state={{.State}}"{{if eq .ViewType "all"}} class="active"{{end}}>All Issues <strong class="pull-right">{{..IssueStats.AllCount}}</strong></a></li>
++ <li><a href="{{.RepoLink}}/issues?state={{.State}}"{{if eq .ViewType "all"}} class="active"{{end}}>All Issues <strong class="pull-right">{{.IssueStats.AllCount}}</strong></a></li>
+ <li><a href="{{.RepoLink}}/issues?type=assigned&state={{.State}}"{{if eq .ViewType "assigned"}} class="active"{{end}}>Assigned to you <strong class="pull-right">{{.IssueStats.AssignCount}}</strong></a></li>
+ <li><a href="{{.RepoLink}}/issues?type=created_by&state={{.State}}"{{if eq .ViewType "created_by"}} class="active"{{end}}>Created by you <strong class="pull-right">{{.IssueStats.CreateCount}}</strong></a></li>
+ <li><a href="{{.RepoLink}}/issues?type=mentioned&state={{.State}}"{{if eq .ViewType "mentioned"}} class="active"{{end}}>Mentioning you <strong class="pull-right">{{.IssueStats.MentionCount}}</strong></a></li>