aboutsummaryrefslogtreecommitdiffstats
path: root/testing/akonadi-notes
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-20 16:54:29 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-20 19:26:43 -0300
commitb879ec50d6772fe3dd5c20ea73a10eef7efdb8fd (patch)
treeb6e053a0b24e8d9ad8a4845c5e1b03349bc99734 /testing/akonadi-notes
parent797593674f15d5806a33456a778f9165b94e0a45 (diff)
downloadaports-b879ec50d6772fe3dd5c20ea73a10eef7efdb8fd.tar.bz2
aports-b879ec50d6772fe3dd5c20ea73a10eef7efdb8fd.tar.xz
testing/akonadi-notes: new aport
Diffstat (limited to 'testing/akonadi-notes')
-rw-r--r--testing/akonadi-notes/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/akonadi-notes/APKBUILD b/testing/akonadi-notes/APKBUILD
new file mode 100644
index 0000000000..296144dcae
--- /dev/null
+++ b/testing/akonadi-notes/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=akonadi-notes
+pkgver=19.04.2
+pkgrel=0
+pkgdesc="Libraries and daemons to implement management of notes"
+arch="all"
+url="https://community.kde.org/KDE_PIM"
+license="LGPL-2.0-or-later"
+depends_dev="qt5-qtbase-dev ki18n-dev kmime-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="14df86f3752ec0e3fc948a6d2d8db2bd81ceaed722d34fc353a91f44acd17257c192bedf2fa32de4c1429871e4dd75dc8ace08f36659f1cb4d9fed53974b1dea akonadi-notes-19.04.2.tar.xz"