aboutsummaryrefslogtreecommitdiffstats
path: root/testing/alacritty
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-03-05 13:05:58 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-05 17:40:40 +0100
commitafa80be363cdaa2566750db5a460149e752cf959 (patch)
treeb62f39d29efa2c67cb46776b5ed1342a288d080e /testing/alacritty
parent605d651b11d9cf3592bcf8fa5eca26689b7c430b (diff)
downloadaports-afa80be363cdaa2566750db5a460149e752cf959.tar.bz2
aports-afa80be363cdaa2566750db5a460149e752cf959.tar.xz
testing/alacritty: check()
Ignore two tests that fails: one depends on X running and the other on a specific font The X server requring test could possibly be solved with spin up xvfb
Diffstat (limited to 'testing/alacritty')
-rw-r--r--testing/alacritty/APKBUILD13
-rw-r--r--testing/alacritty/ignore-ft-fc-tests-font_mated.patch26
-rw-r--r--testing/alacritty/ignore-x11-tests-clipboard_works.patch26
3 files changed, 60 insertions, 5 deletions
diff --git a/testing/alacritty/APKBUILD b/testing/alacritty/APKBUILD
index eb1d885c5a..ba6149b687 100644
--- a/testing/alacritty/APKBUILD
+++ b/testing/alacritty/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=alacritty
pkgver=0.2.9
-pkgrel=0
+pkgrel=1
pkgdesc="A cross-platform, GPU-accelerated terminal emulator"
url="https://github.com/jwilm/alacritty"
arch="x86_64" # via Rust
license="Apache-2.0"
makedepends="rust cargo cmake fontconfig-dev freetype-dev"
subpackages="$pkgname-doc"
-checkdepends="xclip"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jwilm/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jwilm/$pkgname/archive/v$pkgver.tar.gz
+ ignore-ft-fc-tests-font_mated.patch
+ ignore-x11-tests-clipboard_works.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
-options="!check" # TODO: tests require an X server, spin up xvfb for check
export CARGO_HOME="$srcdir"/cargo
export RUSTFLAGS="-C target-feature=-crt-static"
@@ -32,4 +33,6 @@ package() {
install -Dm644 alacritty.yml "$pkgdir"/etc/alacritty/alacritty.yml
}
-sha512sums="c36dea633d5c9faa42956eff47fbd676b5f3a5ef28ae7d6711145f76e99ae92aa8ddcdde1eb5bc700855af5928e2da0b4be3f618bb05aa93c284b73727b2e337 alacritty-0.2.9.tar.gz"
+sha512sums="c36dea633d5c9faa42956eff47fbd676b5f3a5ef28ae7d6711145f76e99ae92aa8ddcdde1eb5bc700855af5928e2da0b4be3f618bb05aa93c284b73727b2e337 alacritty-0.2.9.tar.gz
+c6ae0a47abbd3583d0ccc8c98b71fb73995b2f65d04fee63b34572e44e859bb1cac6e56993a6d478fdb6de42f66e50e723eb01175117aeff1e4035f81ecf5473 ignore-ft-fc-tests-font_mated.patch
+1a9bef3dc02abd5b764cb5f87742ecdcf99f3fcc43deef3dcfb1eddfd1a233ab7c7dec0072a5d17e285c0aff902a5b7847169cb051bcb89cb90904ace1787325 ignore-x11-tests-clipboard_works.patch"
diff --git a/testing/alacritty/ignore-ft-fc-tests-font_mated.patch b/testing/alacritty/ignore-ft-fc-tests-font_mated.patch
new file mode 100644
index 0000000000..1c66bc2b6e
--- /dev/null
+++ b/testing/alacritty/ignore-ft-fc-tests-font_mated.patch
@@ -0,0 +1,26 @@
+From bf9bf36b7eee338ceb0605f61b575eb9e1150d34 Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Tue, 5 Mar 2019 12:21:44 +0100
+Subject: [PATCH] ignore ft::fc::tests::font_mated
+
+Due to:
+ 'ft::fc::tests::font_match' panicked at 'match font monospace', libcore/option.rs:1008:5h
+---
+ font/src/ft/fc/mod.rs | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/font/src/ft/fc/mod.rs b/font/src/ft/fc/mod.rs
+index 5e5deb0..285de66 100644
+--- a/font/src/ft/fc/mod.rs
++++ b/font/src/ft/fc/mod.rs
+@@ -306,6 +306,7 @@ mod tests {
+ use super::*;
+
+ #[test]
++ #[ignore]
+ fn font_match() {
+ let mut pattern = Pattern::new();
+ pattern.add_family("monospace");
+--
+2.21.0
+
diff --git a/testing/alacritty/ignore-x11-tests-clipboard_works.patch b/testing/alacritty/ignore-x11-tests-clipboard_works.patch
new file mode 100644
index 0000000000..ed58e41ddc
--- /dev/null
+++ b/testing/alacritty/ignore-x11-tests-clipboard_works.patch
@@ -0,0 +1,26 @@
+From e444fb149f31df3a87f75632c075575c02141e69 Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Tue, 5 Mar 2019 10:27:33 +0100
+Subject: [PATCH] ignore x11::tests::clipboard_works
+
+Due to:
+ Error: Can't open display: (null)
+---
+ copypasta/src/x11.rs | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/copypasta/src/x11.rs b/copypasta/src/x11.rs
+index c7d9c69..cd2485e 100644
+--- a/copypasta/src/x11.rs
++++ b/copypasta/src/x11.rs
+@@ -157,6 +157,7 @@ mod tests {
+ use ::{Load, Store};
+
+ #[test]
++ #[ignore]
+ fn clipboard_works() {
+ let mut clipboard = Clipboard::new().expect("create clipboard");
+ let arst = "arst";
+--
+2.21.0
+