aboutsummaryrefslogtreecommitdiffstats
path: root/testing/alpine-ipxe/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-04 21:31:47 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-05 14:47:59 +0000
commit70cfa1623083b2723d6df33057d8205b7ddb4760 (patch)
treeb5e53a846081da170a2fe0d58aaa8b375f5fa34a /testing/alpine-ipxe/APKBUILD
parentebc981ae24c5e657a4ba38306d06073ba3079e88 (diff)
downloadaports-70cfa1623083b2723d6df33057d8205b7ddb4760.tar.bz2
aports-70cfa1623083b2723d6df33057d8205b7ddb4760.tar.xz
testing/alpine-ipxe: add support for boot.alpinelinux.org
- add letsencrypt certificate for https - add alpine ipxe ca for signed images support - add undionly support
Diffstat (limited to 'testing/alpine-ipxe/APKBUILD')
-rw-r--r--testing/alpine-ipxe/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/testing/alpine-ipxe/APKBUILD b/testing/alpine-ipxe/APKBUILD
index 5be3a13224..9f9d87c965 100644
--- a/testing/alpine-ipxe/APKBUILD
+++ b/testing/alpine-ipxe/APKBUILD
@@ -3,19 +3,20 @@
pkgname=alpine-ipxe
pkgver=1.0_git20180220
_sha=47849be3a900c546cf92066849be0806f4e611d9
-pkgrel=0
+pkgrel=1
pkgdesc="iPXE build for Alpine Linux netboot"
url="https://boot.alpinelinux.org"
arch="x86 x86_64"
license="GPL-2.0-or-later"
depends=""
makedepends="xz-dev perl coreutils bash syslinux xorriso"
-options="!strip !check" # has not tests
+options="!strip !check" # no tests
install=""
subpackages=""
source="ipxe-$pkgver.tar.gz::https://github.com/ipxe/ipxe/archive/$_sha.tar.gz
DST_Root_CA_X3.pem
- alpine.ipxe
+ alpine-netboot-ca.crt
+ boot.ipxe
"
builddir="$srcdir/ipxe-$_sha/src"
@@ -26,22 +27,27 @@ esac
prepare() {
cd "$builddir"
+ local general opt
+ general="NET_PROTO_IPV6 DOWNLOAD_PROTO_HTTPS IMAGE_TRUST_CMD
+ PING_CMD REBOOT_CMD"
mkdir -p config/local
- echo '#define NET_PROTO_IPV6' >> config/local/general.h
- echo '#define DOWNLOAD_PROTO_HTTPS' >> config/local/general.h
- echo '#define IMAGE_TRUST_CMD' >> config/local/general.h
- echo '#define PING_CMD' >> config/local/general.h
+ for opt in $general; do
+ echo "#define $opt" >> config/local/general.h
+ echo "#define $opt" >> config/local/general.h.efi
+ done
}
build() {
cd "$builddir"
+ # DST_Root_CA_X3.pem is need for https (letsencrypt)
make \
- EMBED="$srcdir/alpine.ipxe" \
- CERT="$srcdir/DST_Root_CA_X3.pem" \
- TRUST="$srcdir/DST_Root_CA_X3.pem" \
+ EMBED="$srcdir/boot.ipxe" \
+ CERT="$srcdir"/alpine-netboot-ca.crt,"$srcdir"/DST_Root_CA_X3.pem \
+ TRUST="$srcdir"/alpine-netboot-ca.crt,"$srcdir"/DST_Root_CA_X3.pem \
bin/ipxe.iso \
bin/ipxe.lkrn \
bin/ipxe.pxe \
+ bin/undionly.kpxe \
bin-$_arch-efi/ipxe.efi
}
@@ -55,8 +61,11 @@ package() {
"$pkgdir"/usr/share/$pkgname/ipxe.efi
install -Dm644 bin/ipxe.iso \
"$pkgdir"/usr/share/$pkgname/ipxe.iso
+ install -Dm644 bin/undionly.kpxe \
+ "$pkgdir"/usr/share/$pkgname/undionly.kpxe
}
sha512sums="abc070ed07970e5307f04f5da3da4916c98016bf0a4115ab04979ecc5e7c452ca5102799ddab926e0ae9867c37c311de785dc93a736bf8f0809d5ea8e3cd3732 ipxe-1.0_git20180220.tar.gz
1f52b62aa9e3ec0656ea3cb5c8e52eda924d58728e64bb03ca6c112858b91b13cf0a9328b105bb232973e240406b240ed14e72b5bd325e82e6fddf3126dbcc58 DST_Root_CA_X3.pem
-5569ba14ed3a164e72edd43e6b9df63fcbc59025c6729f55cbbedf2d513a83075471276a760174432eb2c6da86127a4b68fe1a2cae54408ff53b958261d06f0b alpine.ipxe"
+68030e3f30983ee45c7f740445a246ea0df225becdd0644e06ffdbd84682ac576934dab79fecceb31b70929d81ce85b40301a977862bf7beb042270be21e6d34 alpine-netboot-ca.crt
+5569ba14ed3a164e72edd43e6b9df63fcbc59025c6729f55cbbedf2d513a83075471276a760174432eb2c6da86127a4b68fe1a2cae54408ff53b958261d06f0b boot.ipxe"