aboutsummaryrefslogtreecommitdiffstats
path: root/testing/altermime/makefile-flags.patch
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-02 14:48:09 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-02 14:48:09 +0000
commit67b70103d6fc74186ce861cc554508065dfa0051 (patch)
tree2b55d353ce6981dc3c4b004d53d5f0c082dd7db2 /testing/altermime/makefile-flags.patch
parentc1dcf0a2f96b6605c529ef8f4e334ab661ed976e (diff)
parentcc4a8c13fff3d8637aa0eb0dd2df000036601f42 (diff)
downloadaports-67b70103d6fc74186ce861cc554508065dfa0051.tar.bz2
aports-67b70103d6fc74186ce861cc554508065dfa0051.tar.xz
Merge git://git.alpinelinux.org/aports
Conflicts: testing/openxcap/APKBUILD
Diffstat (limited to 'testing/altermime/makefile-flags.patch')
-rw-r--r--testing/altermime/makefile-flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/altermime/makefile-flags.patch b/testing/altermime/makefile-flags.patch
new file mode 100644
index 0000000000..71a399051e
--- /dev/null
+++ b/testing/altermime/makefile-flags.patch
@@ -0,0 +1,21 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -9,7 +9,8 @@
+ # opposite of a disclaimer.
+ #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS?=-Wall -Werror -g -I. -O2
++CFLAGS+=$(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +20,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} altermime.c ${OBJS} ${LDFLAGS} -o altermime
+
+
+ # Build Install