aboutsummaryrefslogtreecommitdiffstats
path: root/testing/android-tools
diff options
context:
space:
mode:
authorJoe Holden <jwh@zorins.us>2019-03-01 13:48:50 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-03-03 19:58:59 +0000
commit67283cdbf6ef0ce2912bd28297714d6bb3976a38 (patch)
treeb8b696a53156555dbb2f75a1c23a1a19ba70c1bf /testing/android-tools
parentf719544534b3316d19c83ed79a7c3f93957ceede (diff)
downloadaports-67283cdbf6ef0ce2912bd28297714d6bb3976a38.tar.bz2
aports-67283cdbf6ef0ce2912bd28297714d6bb3976a38.tar.xz
testing/android-tools: build on arm
Built on aarch64 and armv7 by mps@IRC, runtime tested on armhf by myself
Diffstat (limited to 'testing/android-tools')
-rw-r--r--testing/android-tools/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/android-tools/APKBUILD b/testing/android-tools/APKBUILD
index 17536de255..9152b75786 100644
--- a/testing/android-tools/APKBUILD
+++ b/testing/android-tools/APKBUILD
@@ -3,10 +3,10 @@
pkgname=android-tools
pkgver=9.0.0_p33
_realver=${pkgver/_p/_r}
-pkgrel=0
+pkgrel=1
pkgdesc="Android platform tools"
url="https://sites.google.com/a/android.com/tools/"
-arch="x86 x86_64"
+arch="x86 x86_64 aarch64 armv7 armhf"
license="Apache-2.0 MIT"
depends=""
depends_dev=""
@@ -18,6 +18,10 @@ builddir="$srcdir/$pkgname-$_realver"
build() {
cd "$builddir"
+ case "$CARCH" in
+ aarch64|arm*) CXXFLAGS="$CXXFLAGS -Wno-error=attributes";;
+ esac
+
mkdir build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \