aboutsummaryrefslogtreecommitdiffstats
path: root/testing/animatch
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-24 22:39:48 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-25 00:19:31 +0100
commit8d0ed5f29f8c46637cde50b03878a5cebd3296a1 (patch)
treebc7a9561e18f2453f798130f0fa47e93ce554faa /testing/animatch
parent35eed014ef9578d5de5560d775954cb3643456ac (diff)
downloadaports-8d0ed5f29f8c46637cde50b03878a5cebd3296a1.tar.bz2
aports-8d0ed5f29f8c46637cde50b03878a5cebd3296a1.tar.xz
testing/animatch: new aport
Diffstat (limited to 'testing/animatch')
-rw-r--r--testing/animatch/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/animatch/APKBUILD b/testing/animatch/APKBUILD
new file mode 100644
index 0000000000..57b4ef742d
--- /dev/null
+++ b/testing/animatch/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=animatch
+pkgver=1.0.0
+pkgrel=0
+_commit_libsuperderpy="e9d645ecee0ff7f72c9b8f05b920289a26a20cdb"
+arch="all"
+url="https://gitlab.com/HolyPangolin/animatch"
+pkgdesc="Animatch is a match-three game with cute animals"
+license="GPL-3.0-or-later"
+makedepends="cmake ninja allegro-dev mesa-dev"
+source="https://gitlab.com/HolyPangolin/animatch/-/archive/v$pkgver/animatch-v$pkgver.tar.gz
+ libsuperderpy-$_commit_libsuperderpy.tar.gz::https://gitlab.com/dosowisko.net/libsuperderpy/-/archive/$_commit_libsuperderpy.tar.gz"
+subpackages="$pkgname-static $pkgname-doc"
+options="!check" # No tests
+builddir="$srcdir/$pkgname-v$pkgver"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+
+ # libsuperderpy doesn't have a stable ABI yet so build it statically to prevent conflicts with other packages using it
+ rmdir "$builddir"/libsuperderpy
+ mv "$srcdir"/libsuperderpy-$_commit_libsuperderpy "$builddir"/libsuperderpy
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DLIBSUPERDERPY_IMGUI=OFF \
+ -GNinja
+ ninja
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="1076517ee332dd2b13f8f78054787aeaa60dafdc76c6455936e04f1509618ffb3954589809ab3afbe38b268570960445919ea856bf63bdc48eda92e5c602c267 animatch-v1.0.0.tar.gz
+70a035db24b15f44ae5feac8c8459c16f6c068d5e0f93e9ba37f2772597d32d0c37c61387abc0718efa85c3fa7afc2d7f70b3c2088f496fb2a01532b72bef25e libsuperderpy-e9d645ecee0ff7f72c9b8f05b920289a26a20cdb.tar.gz"