aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ansible-lint
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2018-08-17 22:55:12 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-12 12:40:16 +0000
commit30cef5eeae5d64d6a2acd264a001a2710df5558f (patch)
treecef74d7ca208388ee930af0d3d4af7a41ccf078b /testing/ansible-lint
parent12262533592bede07a1f778ce3f658e880a530be (diff)
downloadaports-30cef5eeae5d64d6a2acd264a001a2710df5558f.tar.bz2
aports-30cef5eeae5d64d6a2acd264a001a2710df5558f.tar.xz
testing/ansible-lint: move
Moved from testing/py-ansible-lint. Naming is difficult IMO. The wiki states [1]: > There’s no exact rule if the prefix should be used for tools and > applications written in Python, it varies. To be logical: - The upstream ansible-lint project supports both Python 2 and Python 3 - ansible-lint depends upon ansible. - ansible is only packaged for Python 3 in Alpine Linux. - ansible is not named with a py3- prefix. - To be consistent with ansible this package should not have the prefix [1] https://wiki.alpinelinux.org/wiki/APKBUILD_examples:Python
Diffstat (limited to 'testing/ansible-lint')
-rw-r--r--testing/ansible-lint/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ansible-lint/APKBUILD b/testing/ansible-lint/APKBUILD
new file mode 100644
index 0000000000..4786a581ce
--- /dev/null
+++ b/testing/ansible-lint/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ansible-lint
+pkgver=3.4.23
+pkgrel=0
+pkgdesc="A tool to check ansible playbooks"
+url="https://github.com/ansible/ansible-lint"
+arch="noarch"
+license="MIT"
+depends="ansible py3-six"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+provides="py3-ansible-lint=$pkgver-r$pkgrel" # for backward compatibility
+replaces="py3-ansible-lint" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ cd "$builddir/build/lib"
+ python3 -c "import ansiblelint"
+}
+
+sha512sums="b7754283943af88b8e11950b142bc36542c10d6f761a78f87d27954c62b70c77ae1d8925611d33f4daefc3c02d5fb217c419e3271eee33573a1cd48473bbf22d ansible-lint-3.4.23.tar.gz"