aboutsummaryrefslogtreecommitdiffstats
path: root/testing/anytun
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:28:39 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:28:39 +0000
commit55738ff3967d067c059212161b02a8b9c2d04108 (patch)
treed606c38f8e8e99f1faab353a8aecf754d2435d0f /testing/anytun
parente1858a4746c3817c4b0f36464548655c637d3e86 (diff)
downloadaports-55738ff3967d067c059212161b02a8b9c2d04108.tar.bz2
aports-55738ff3967d067c059212161b02a8b9c2d04108.tar.xz
community/anytun: moved from testing
Diffstat (limited to 'testing/anytun')
-rw-r--r--testing/anytun/APKBUILD61
-rw-r--r--testing/anytun/anytun.initd155
-rw-r--r--testing/anytun/boost-mt.patch26
-rw-r--r--testing/anytun/fix-werror-compile-flags.patch15
4 files changed, 0 insertions, 257 deletions
diff --git a/testing/anytun/APKBUILD b/testing/anytun/APKBUILD
deleted file mode 100644
index d4cb1f2536..0000000000
--- a/testing/anytun/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=anytun
-pkgver=0.3.6
-pkgrel=0
-pkgdesc="Secure anycast tunneling protocol implementation for flexible and fault-tolerant VPNs"
-url="http://www.anytun.org"
-arch="all"
-license="GPL3"
-depends=""
-depends_dev="openssl-dev boost-dev linux-headers"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.anytun.org/download/$pkgname-$pkgver.tar.gz
- boost-mt.patch
- fix-werror-compile-flags.patch
- $pkgname.initd"
-
-_builddir="$srcdir"/$pkgname-$pkgver/src
-prepare() {
- local i
- cd "$_builddir"
- cd ..
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --use-ssl-crypto \
- --examplesdir=/usr/share/docs || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- mkdir -p ${pkgdir}/var/run/anytun ${pkgdir}/var/run/anytun-controld &>/dev/null
- make install DESTDIR="${pkgdir}"
- rm "${pkgdir}"/etc/init.d/$pkgname
- install -Dm 755 "$srcdir"/$pkgname.initd "${pkgdir}"/etc/init.d/$pkgname
-}
-
-md5sums="90683b03a3f438639c5f2de0730dcf5e anytun-0.3.6.tar.gz
-d7220eae296c814ee100d8ca1f5cf19a boost-mt.patch
-3122d09abb4d8f24043e11bdbf5b8229 fix-werror-compile-flags.patch
-d429ba9feaaf15bb268b811eccc71862 anytun.initd"
-sha256sums="afef9ba3002df9d1bd2eba2ec2ab9a9551a0822bfa9664bfbc3c97a6e2e313a8 anytun-0.3.6.tar.gz
-31dca9b29da41ed338d12ff96171b1f2a84013f689af0965c2d97f2fbcf0b499 boost-mt.patch
-a07966d0866dc18b88682fffa3892535ed6422cb1200c7bdbeec2a019a8a34b4 fix-werror-compile-flags.patch
-f2390be3b27d2a208e4d77bf776d62c2dd9a92a79a30e5394188b82af6f55037 anytun.initd"
-sha512sums="470bec0ed96fd8cd7921d8a110272578020b666e8852c9e52a88da9957b2d641cd2b43cc8c9e453331a9f848282ea4516e304d71add6fea71a7ce3e6d76117b1 anytun-0.3.6.tar.gz
-e19522a26529bb16591ed724d499c3b7fd7060e937eadc93f7719c29aaa604b953c59b94024efe2227331741ba5bbde084619dd42071cf086ef803906e6678a7 boost-mt.patch
-f9705cf1879a8f50bc53fae04b48a88baa9aa5f7f1035b0ec737bdacaa21007da76b8985e1b9cba05936c9dc94200cb3c4ff39492755c8f219e42ee73ecf1431 fix-werror-compile-flags.patch
-a31455058e0ac60ed9457c79eea789ce19ba49abc200b59c0d8390eb0c3b6f09813177f9b679fb8ac69ac7b0be862e4604d19298ae4cd79925511fff3963e93d anytun.initd"
diff --git a/testing/anytun/anytun.initd b/testing/anytun/anytun.initd
deleted file mode 100644
index 0767a73802..0000000000
--- a/testing/anytun/anytun.initd
+++ /dev/null
@@ -1,155 +0,0 @@
-#!/sbin/openrc-run
-# Distributed under the terms of the GNU General Public License v3
-# Written by Bernhard Tittelbach based on examples from Gentoo, openvpn and anytun debian init.rd script
-
-opts="${opts} reload"
-depend() {
- need net
- use dns
- after bootmisc
-}
-
-DAEMON=/usr/sbin/anytun
-ANYTUNCONFIG=/usr/bin/anytun-config
-CONTROLDAEMON=/usr/bin/anytun-controld
-NAME=anytun
-DESC=anytun
-CONFIG_DIR=/etc/anytun
-VARCONFIG_DIR=/var/run/anytun-controld
-VARRUN_DIR=/var/run/anytun
-
-VPN=${SVCNAME#*.}
-[ "$VPN" = "$SVCNAME" ] && VPN=""
-
-# Include anytun defaults if available
-if [ -f /etc/conf.d/anytun ] ; then
- . /etc/conf.d/anytun
-fi
-
-test -x $DAEMON || exit 1
-
-
-start_vpn () {
- if [ -f $CONFIG_DIR/$NAME/config ] ; then
- POSTUP=''
- test -f $CONFIG_DIR/$NAME/post-up.sh && POSTUP="-x $CONFIG_DIR/$NAME/post-up.sh"
- CHROOTDIR=`grep '^chroot' < $CONFIG_DIR/$NAME/config | sed 's/chroot\s*//'`
- if [ -n "$CHROOTDIR" ] ; then
- test -d $CHROOTDIR || mkdir -p $CHROOTDIR
- fi
- test -d $VARRUN_DIR || mkdir -p $VARRUN_DIR
- DAEMONARG=`sed 's/#.*//' < $CONFIG_DIR/$NAME/config | grep -e '\w' | sed 's/^/--/' | tr '\n' ' '`
- start-stop-daemon --start --pidfile $VARRUN_DIR/${NAME}.pid --exec $DAEMON -- --write-pid $VARRUN_DIR/${NAME}.pid $POSTUP \
- $DAEMONOPTS $DAEMONARG || return 1
- else
- eerror "no config found"
- return 1
- fi
- start_configd
- return 0
-}
-stop_vpn () {
- start-stop-daemon --stop --pidfile $PIDFILE --exec $DAEMON
- rm -f $PIDFILE
- stop_configd
-}
-
-start_configd () {
- if [ -d $CONFIG_DIR/$NAME/conf.d ] ; then
- test -d $VARCONFIG_DIR || mkdir -p $VARCONFIG_DIR
- chmod 700 $VARCONFIG_DIR
- rm -f $VARCONFIG_DIR/$NAME 2>/dev/null
- KDPRF=`sed 's/#.*//' < $CONFIG_DIR/$NAME/config | grep -e 'kd-prf' | sed 's/^/ --/' | xargs echo`
- for CLIENTPATH in $CONFIG_DIR/$NAME/conf.d/* ; do
- DAEMONARG=`sed 's/#.*//' < $CLIENTPATH | grep -e '\w' | sed 's/^/ --/' | xargs echo`
- $ANYTUNCONFIG $DAEMONARG $CIPHER $AUTHALGO $KDPRF >> $VARCONFIG_DIR/$NAME
- done
- CONTROLHOST=`sed 's/#.*//' < $CONFIG_DIR/$NAME/config | grep -e 'control-host' | sed 's/^/ --/'i | xargs echo`
- start-stop-daemon --start --pidfile $VARCONFIG_DIR/${NAME}.pid --exec $CONTROLDAEMON \
- -- -f $VARCONFIG_DIR/$NAME $DAEMONOPTS $CONTROLHOST --write-pid $VARCONFIG_DIR/${NAME}.pid
- fi
-}
-stop_configd () {
- if [ -d $CONFIG_DIR/$NAME/conf.d ] ; then
- start-stop-daemon --stop --pidfile $VARCONFIG_DIR/${NAME}.pid --exec $CONTROLDAEMON
- rm -f $VARCONFIG_DIR/${NAME}.pid
- fi
-}
-
-start () {
- if test -z "$VPN" ; then
- if [ -f $CONFIG_DIR/autostart ] ; then
- for NAME in `sed 's/#.*//' < $CONFIG_DIR/autostart | grep -e '\w'`; do
- ebegin "Starting ${DESC} VPN: ${NAME}"
- start_vpn
- eend $?
- done
- else
- eerror "no config found"
- return 1;
- fi
- else
- NAME="$VPN"
- ebegin "Starting ${DESC} VPN: ${NAME}"
- start_vpn
- eend $?
- fi
-}
-
-stop () {
- if test -z "$VPN" ; then
- for PIDFILE in ${VARRUN_DIR}/*.pid ; do
- NAME=`basename $PIDFILE .pid`
- ebegin "Stopping ${DESC} VPN: ${NAME}"
- stop_vpn
- eend $?
- done
- else
- if test -e ${VARRUN_DIR}/${VPN}.pid ; then
- PIDFILE=${VARRUN_DIR}/${VPN}.pid
- NAME=`basename $PIDFILE .pid`
- ebegin "Stopping ${DESC} VPN: ${NAME}"
- stop_vpn
- eend $?
- else
- eerror " failure: No such tunnel is running: $VPN"
- fi
- fi
-}
-
-reload () {
- if test -z "$VPN" ; then
- for PIDFILE in ${VARRUN_DIR}/*.pid ; do
- NAME=`basename $PIDFILE .pid`
- if [ -d $CONFIG_DIR/$NAME/conf.d ] ; then
- ebegin "Reloading ${DESC} VPN: ${NAME}"
- stop_vpn
- start_vpn
- eend $?
- else
- ebegin "Reloading ${DESC} VPN: ${NAME}"
- stop_configd
- start_configd
- eend $?
- fi
- done
- else
- if test -e ${VARRUN_DIR}/${VPN}.pid ; then
- PIDFILE=${VARRUN_DIR}/${VPN}.pid
- NAME=`basename $PIDFILE .pid`
- if [ -d $CONFIG_DIR/$NAME/conf.d ] ; then
- ebegin "Reloading ${DESC} VPN: ${NAME}"
- stop_vpn
- start_vpn
- eend $?
- else
- ebegin "Reloading ${DESC} VPN: ${NAME}"
- stop_configd
- start_configd
- eend $?
- fi
- else
- eerror "failure: No such tunnel is running: $VPN"
- fi
- fi
-}
diff --git a/testing/anytun/boost-mt.patch b/testing/anytun/boost-mt.patch
deleted file mode 100644
index 9596d4c234..0000000000
--- a/testing/anytun/boost-mt.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/anyrtpproxy/Makefile b/src/anyrtpproxy/Makefile
-index ef15ff3..190cb9d 100644
---- a/src/anyrtpproxy/Makefile
-+++ b/src/anyrtpproxy/Makefile
-@@ -47,7 +47,7 @@ CFLAGS = -g -Wall
- CXX = g++
- CXXFLAGS = -g -Wall
- LD = g++
--LDFLAGS = -g -Wall -O2 -lboost_thread -lboost_serialization -lboost_system
-+LDFLAGS = -g -Wall -O2 -lboost_thread-mt -lboost_serialization -lboost_system
-
- OBJS = anyrtpproxy.o \
- ../signalController.o \
-diff --git a/src/configure b/src/configure
-index f070150..eb4e131 100755
---- a/src/configure
-+++ b/src/configure
-@@ -215,7 +215,7 @@ case $TARGET in
- ln -sf posix/posixDaemon.h daemonService.h
- ln -sf posix/posixDaemon.cpp daemonService.cpp
- echo "loading Linux specific TUN Device"
-- LDFLAGS=$LDFLAGS' -lboost_thread -lboost_serialization -lboost_system -lboost_date_time -lpthread'
-+ LDFLAGS=$LDFLAGS' -lboost_thread-mt -lboost_serialization -lboost_system -lboost_date_time -lpthread'
- LOG_TARGETS='-DLOG_SYSLOG -DLOG_FILE -DLOG_STDOUT'
- ;;
- OpenBSD|FreeBSD|NetBSD|GNU/kFreeBSD)
diff --git a/testing/anytun/fix-werror-compile-flags.patch b/testing/anytun/fix-werror-compile-flags.patch
deleted file mode 100644
index 919a74b24e..0000000000
--- a/testing/anytun/fix-werror-compile-flags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/src/configure b/src/configure
-index 65a0c74..357628e 100755
---- a/src/configure
-+++ b/src/configure
-@@ -217,8 +217,8 @@ if [ -n "$ERRORS" ] && [ $EBUILD_COMPAT -ne 1 ]; then
- fi
-
- if [ $USE_CLANG -eq 0 ]; then
-- CXXFLAGS='-g -Wall -Werror -Wno-error=unused-variable -O2'
-- LDFLAGS='-g -Wall -Werror -O2'
-+ CXXFLAGS='-g -Wall -Wno-error=unused-variable -O2'
-+ LDFLAGS='-g -Wall -O2'
- COMPILER='g++'
- else
- CXXFLAGS='-g -O2'