aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache2-mod-perl/APKBUILD
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2015-11-20 16:12:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-24 13:02:55 +0000
commit48ee788e89b0bca773dc97d15a215c004a8a86d7 (patch)
treeefc45a8385be0cbf93bff50f215ac5220282b9e5 /testing/apache2-mod-perl/APKBUILD
parent1d04c940d71566ac1bd81b98df86ae8f972ea343 (diff)
downloadaports-48ee788e89b0bca773dc97d15a215c004a8a86d7.tar.bz2
aports-48ee788e89b0bca773dc97d15a215c004a8a86d7.tar.xz
testing/apache2-mod-perl: more refined patch to work with perl 5.22
This patch is replaces the previous one: http://patchwork.alpinelinux.org/patch/851/ - all unused patches and post-install script are removed - added the latest patch from https://rt.cpan.org/Public/Bug/Display.html?id=101962#txn-1558194 - many tests are fail, so 'make test' is not included in build() - some minor cleanups in APKBUILD Now apache not crashes to segfault with this module ;)
Diffstat (limited to 'testing/apache2-mod-perl/APKBUILD')
-rw-r--r--testing/apache2-mod-perl/APKBUILD54
1 files changed, 20 insertions, 34 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
index 1be93cfeb5..284fdbf29b 100644
--- a/testing/apache2-mod-perl/APKBUILD
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -1,28 +1,30 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Matt Smith <mcs@darkregion.net>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=apache2-mod-perl
-_realname=mod_perl
+_pkgreal=mod_perl
pkgver=2.0.9
_pkgver=${pkgver/_rc1/-rc1}
-pkgrel=1
+pkgrel=2
pkgdesc="Perl Module for Apache2"
url="http://perl.apache.org/"
arch="all"
license="ASL 2.0"
-depends="apache2 perl"
+depends="apache2"
depends_dev="$pkgname"
makedepends="$depends_dev apache2-dev perl-dev perl-linux-pid apr-dev apr-util-dev"
-install="$pkgname.post-install"
+install=""
subpackages="$pkgname-doc $pkgname-dev"
-source="http://www.eu.apache.org/dist/perl/mod_perl-$pkgver.tar.gz
- $pkgname.apache2.conf"
+source="http://www.eu.apache.org/dist/perl/$_pkgreal-$pkgver.tar.gz
+ https://rt.cpan.org/Public/Ticket/Attachment/1549932/827564/env2.patch
+ $pkgname.conf"
-_builddir="$srcdir"/${_realname}-${_pkgver}
+_builddir="$srcdir"/${_pkgreal}-${_pkgver}
prepare() {
cd "$_builddir"
for i in $source; do
case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ *.patch) msg $i; [ ! -f "$srcdir"/$i ]; patch -p$? -i "$srcdir"/${i##*/} || return 1;;
esac
done
}
@@ -33,6 +35,7 @@ build() {
make xs_generate
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
+ MP_CCOPTS=-fgnu89-inline \
MP_APXS=/usr/bin/apxs \
MP_APR_CONFIG=/usr/bin/apr-1-config || return 1
make || return 1
@@ -42,34 +45,17 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
-
- # install the apache2 config
- install -Dm644 "$srcdir"/$pkgname.apache2.conf \
- "$pkgdir"/etc/apache2/conf.d/perl-module.conf || return 1
-}
-
-doc() {
- arch="noarch"
-
- # man pages
- mkdir -p "$subpkgdir"/usr/share/man || return 1
- mv "$pkgdir"/usr/share/man/man* "$subpkgdir"/usr/share/man/ \
- || return 1
-
- # doc files
- _docs="BRANCHING Changes INSTALL LICENSE MANIFEST NOTICE README \
- README-SVN RELEASE STATUS SVN-MOVE"
- for _doc in $_docs; do
- install -Dm644 "$_builddir"/$_doc \
- "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
- done
- cp -ra "$_builddir"/docs/ "$subpkgdir"/usr/share/doc/$pkgname/ \
- || return 1
+ rm -fr "$pkgdir"/usr/bin
+ install -Dm644 "$srcdir"/$pkgname.conf \
+ "$pkgdir"/etc/apache2/conf.d/$_pkgreal.conf || return 1
}
md5sums="fdab9a145bf35f54fce997c96c76f8e2 mod_perl-2.0.9.tar.gz
-86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf"
+f8c2de81056faea64a4d5e53fef9fb99 env2.patch
+86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.conf"
sha256sums="0260f26ab771c1c95fadc67544b3400e420bb30b8a77565d2d02ad05498ef52b mod_perl-2.0.9.tar.gz
-92dfc84c1506f34fc55cb65f4f2b0399254d811a03c5bcea1e6cf010e60a5227 apache2-mod-perl.apache2.conf"
+6d2cd5d39dc6a53e5c9e2211f6e59d195af582ffa0313f61cb08d1654a456a6f env2.patch
+92dfc84c1506f34fc55cb65f4f2b0399254d811a03c5bcea1e6cf010e60a5227 apache2-mod-perl.conf"
sha512sums="421d385f0d5d04cbe8c1e9559960eea86a017fa1bed88e614009143550baf852e2345001faff1fb849d9b3e6383786e0011f45ebc3e7d26ad57651fbad4e2f2c mod_perl-2.0.9.tar.gz
-716650058af077b0494833301f3dfdf517499bdb2021427431cacc7f63e5fe520cd6f5f7daee44bed15e257c9a2d1fb7d18a75954455fa894dd24a8ef32af50b apache2-mod-perl.apache2.conf"
+add28358a740005baa0891d910ea8597341a3cb07f6baa629059c782d90282b4a1e8275d2fffe6d90d0faac9820037e5e06ab4196d1beb6a663634b7f0832bdd env2.patch
+716650058af077b0494833301f3dfdf517499bdb2021427431cacc7f63e5fe520cd6f5f7daee44bed15e257c9a2d1fb7d18a75954455fa894dd24a8ef32af50b apache2-mod-perl.conf"