aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache2-mod-realdoc/APKBUILD
diff options
context:
space:
mode:
authorKeith <keithy@consultant.com>2018-02-19 01:43:17 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-04 20:17:08 +0000
commit0675ed6d43e7090eb9802d47fa7cbc2eb6324570 (patch)
treeb498a13066957ef91d088dbdedd96705cf3a8fa4 /testing/apache2-mod-realdoc/APKBUILD
parent2fac56ca82fab285ce638218b2889663cbe33687 (diff)
downloadaports-0675ed6d43e7090eb9802d47fa7cbc2eb6324570.tar.bz2
aports-0675ed6d43e7090eb9802d47fa7cbc2eb6324570.tar.xz
testing/apache2-mod-realdoc: new aport
https://github.com/etsy/mod_realdoc Ensures realpath DocumentRoot for the whole request
Diffstat (limited to 'testing/apache2-mod-realdoc/APKBUILD')
-rw-r--r--testing/apache2-mod-realdoc/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/apache2-mod-realdoc/APKBUILD b/testing/apache2-mod-realdoc/APKBUILD
new file mode 100644
index 0000000000..1d789d5a06
--- /dev/null
+++ b/testing/apache2-mod-realdoc/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Keith <keithy@consultant.com>
+# Maintainer: Keith <keithy@consultant.com>
+pkgname=apache2-mod-realdoc
+pkgver=1
+pkgrel=1
+pkgdesc="Ensures realpath DocumentRoot for the whole request."
+url="https://github.com/etsy/mod_realdoc"
+docs="https://codeascraft.com/2013/07/01/atomic-deploys-at-etsy"
+arch="all"
+license="MIT"
+depends="apache2"
+makedepends="apache2-dev"
+options="!check"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/etsy/mod_realdoc/archive/f7fbf65256e7e843c42dee36517e6291b457643c.tar.gz
+ mod-realdoc.conf"
+builddir="$srcdir/mod_realdoc-f7fbf65256e7e843c42dee36517e6291b457643c"
+build() {
+ cd "$builddir"
+ apxs -c mod_realdoc.c
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+
+ # the install step used by rasmus
+ # apxs -i -n realdoc mod_realdoc.la
+
+ /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/build-1/libtool' mod_realdoc.la "$pkgdir"/usr/lib/apache2
+
+ install -D -m644 ../../mod-realdoc.conf "$pkgdir"/etc/apache2/conf.d/mod-realdoc.conf
+}
+
+sha512sums="f7ef7c80f150e5c497ee86df8aad47008797b22cc4315ea262f39c0e7f8f7cf9146c372bc170c013dc0d29892a0a51d872b07f2f119ff1ca0538a08f5f262fa4 apache2-mod-realdoc-1.tar.gz
+c317ac82433150a84cba3633ab0e55afe1f35ea1941e117a4760479b3d1ebbcaa1f081b36d198a381e30d699e3c028c7532c41dd53b3038c09a3401191f80b44 mod-realdoc.conf"