aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apt-dater-host
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-09-19 17:11:35 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 08:59:21 +0000
commita6dde8614b613a80d9692a1fb1a501036e40d4a3 (patch)
treefbd49652add6d44028dad51c86346646d3f8fcf9 /testing/apt-dater-host
parentba013bb188ce088b03a708fdcc7e2226c36fd29f (diff)
downloadaports-a6dde8614b613a80d9692a1fb1a501036e40d4a3.tar.bz2
aports-a6dde8614b613a80d9692a1fb1a501036e40d4a3.tar.xz
testing/apt-dater-host: checkbashism in check()
Fix the last bashism as well
Diffstat (limited to 'testing/apt-dater-host')
-rw-r--r--testing/apt-dater-host/APKBUILD10
-rw-r--r--testing/apt-dater-host/apt-dater-host-fix-bashisms.patch12
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/apt-dater-host/APKBUILD b/testing/apt-dater-host/APKBUILD
index de4383693b..eef272209d 100644
--- a/testing/apt-dater-host/APKBUILD
+++ b/testing/apt-dater-host/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
pkgname=apt-dater-host
pkgver=1.0.0
-pkgrel=4
+pkgrel=5
pkgdesc="Host helper application for apt-dater"
url="https://github.com/DE-IBH/apt-dater-host"
arch="noarch"
license="GPL2+"
-checkdepends="bats"
+checkdepends="bats checkbashisms"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/DE-IBH/$pkgname/archive/v$pkgver.tar.gz
initial-support-for-alpine.patch
@@ -15,6 +15,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/DE-IBH/$pkgname/archive/v$pk
0001-apk-add-some-unit-tests-called-via-make-check.patch
0002-apk-handle-packages-installed-with-Repository_pinnin.patch
0003-apk-an-alpine-package-can-be-held-back-with-as-well.patch
+ apt-dater-host-fix-bashisms.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -29,6 +30,8 @@ prepare() {
check() {
cd "$builddir"/apk
make check
+
+ checkbashisms ./apt-dater-host
}
package() {
@@ -44,4 +47,5 @@ sha512sums="db750d1c33e425de315ecfe4d7d1a177b64432070ce355adfe24ebf7510f4f3d6452
105b10a811a39b78ed8764318bceb7c44f7dd9781f49bd7b8ce09fc7011e3dd88b41037a5a82f9b05b1324914fab4baa87c836f613cafea606554abe7b35c139 try-to-use-virt-what.patch
d316c9cb8d465112b7c838103a6d0fe5acf437819bf3a7e8d51a2e317cded71d53a36f6db980f71f5aa789ee28c9ffbfd2af2a333e3ae16fcd4ac05cf48c84bc 0001-apk-add-some-unit-tests-called-via-make-check.patch
ee606e48869c83b4f36515e3ffc23be1f99779aab848414601cf86722122fa2c433283dba6872571ec47af1a0b83d38f21dfa054221f7196b0273e7fce4904e5 0002-apk-handle-packages-installed-with-Repository_pinnin.patch
-bea084d448e1679e3910cb642177182a5ae75505b334b909989a4cdfaf1b5059286f90fcfcd39deb3e504a1816e5ba662e4c4c4f229493847a666396d1138f36 0003-apk-an-alpine-package-can-be-held-back-with-as-well.patch"
+bea084d448e1679e3910cb642177182a5ae75505b334b909989a4cdfaf1b5059286f90fcfcd39deb3e504a1816e5ba662e4c4c4f229493847a666396d1138f36 0003-apk-an-alpine-package-can-be-held-back-with-as-well.patch
+6f695e1b1785f88217b5a32c509b5cb3c7a3f70069b042ad9770a4c1e86c4477abab2763579130f65e0c880976eb9f292bed3b42dda0d25e801696db479e55e8 apt-dater-host-fix-bashisms.patch"
diff --git a/testing/apt-dater-host/apt-dater-host-fix-bashisms.patch b/testing/apt-dater-host/apt-dater-host-fix-bashisms.patch
new file mode 100644
index 0000000000..8af008f38d
--- /dev/null
+++ b/testing/apt-dater-host/apt-dater-host-fix-bashisms.patch
@@ -0,0 +1,12 @@
+diff -urN a/apk/apt-dater-host b/apk/apt-dater-host
+--- a/apk/apt-dater-host 2017-09-19 17:29:23.873543499 +0200
++++ b/apk/apt-dater-host 2017-09-19 17:29:53.406954004 +0200
+@@ -168,7 +168,7 @@
+ shift
+
+ proxy="/etc/profile.d/proxy.sh"
+- [ -r $proxy ] && source $proxy
++ [ -r $proxy ] && . $proxy
+
+ cmd="$ROOT_CMD $*"
+ $cmd