aboutsummaryrefslogtreecommitdiffstats
path: root/testing/armagetronad
diff options
context:
space:
mode:
authorVictor Diego Alegandro Diaz Urbaneja <sodomon2@gmail.com>2019-09-23 02:47:19 -0400
committerRasmus Thomsen <oss@cogitri.dev>2019-09-26 17:45:29 +0200
commit0d4763b6c9deae44499f4d39147406a33816453c (patch)
tree85af4be72eee8f2b20fb574d5f8259988d00343b /testing/armagetronad
parent77daa86b6baa5a75b184d4ffc56fdb29d9e9fb9c (diff)
downloadaports-0d4763b6c9deae44499f4d39147406a33816453c.tar.bz2
aports-0d4763b6c9deae44499f4d39147406a33816453c.tar.xz
testing/armagetronad:new aport
A Tron Clone in 3D. http://armagetronad.net/
Diffstat (limited to 'testing/armagetronad')
-rw-r--r--testing/armagetronad/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/armagetronad/APKBUILD b/testing/armagetronad/APKBUILD
new file mode 100644
index 0000000000..de003d85f6
--- /dev/null
+++ b/testing/armagetronad/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
+# Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
+pkgname=armagetronad
+pkgver=0.2.8.3.4
+pkgrel=0
+pkgdesc="A Tron Clone in 3D."
+url="http://armagetronad.net/"
+arch="all"
+license="GPL-1.0-only"
+makedepends="sdl_image-dev sdl_mixer-dev ftgl-dev libxml2-dev"
+subpackages="$pkgname-doc $pkgname-openrc"
+options="!check" #the tests are deactivated because the make check has not been declared
+source="https://launchpad.net/armagetronad/${pkgver%.*.*}/$pkgver/+download/armagetronad-$pkgver.src.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --disable-useradd \
+ --enable-dirty \
+ --enable-music \
+ --enable-armathentication \
+ --enable-master \
+ --enable-krawall \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/libexec \
+ --datadir=/usr/share \
+ --sysconfdir=/usr/share \
+ --sharedstatedir=/usr/share \
+ --localstatedir=/var \
+ --libdir=/usr/share \
+ --includedir=/usr/share \
+ --docdir=/usr/share/doc/armagetronad
+ make
+}
+
+
+package() {
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="b6564a67e37dae095f56fb0b98c5d80e09ea220e7416b549978e3ab4b018eb01026e4a5d339d46aaaf4edc7b5e1d707cf6a172f79ef367414a1c7636f14da234 armagetronad-0.2.8.3.4.src.tar.gz"