aboutsummaryrefslogtreecommitdiffstats
path: root/testing/asterisk-audio-konf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-27 09:37:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-27 09:38:45 +0000
commitc17f42bb70c2a0cc84124ab8b1798382b88ee6c2 (patch)
tree968792b17969a96104560e652ce049449bc313ec /testing/asterisk-audio-konf
parentf12146d5ba7a85010295e4142ca35d9ea1588fb2 (diff)
downloadaports-c17f42bb70c2a0cc84124ab8b1798382b88ee6c2.tar.bz2
aports-c17f42bb70c2a0cc84124ab8b1798382b88ee6c2.tar.xz
testing/asterisk-audio-konf: new aport
A fork of AppKonference focused entirely on audio conferencing http://github.com/jthomerson/AsteriskAudioKonf/
Diffstat (limited to 'testing/asterisk-audio-konf')
-rw-r--r--testing/asterisk-audio-konf/0001-create-install-dir.patch24
-rw-r--r--testing/asterisk-audio-konf/APKBUILD66
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/asterisk-audio-konf/0001-create-install-dir.patch b/testing/asterisk-audio-konf/0001-create-install-dir.patch
new file mode 100644
index 0000000000..9d2f548eb1
--- /dev/null
+++ b/testing/asterisk-audio-konf/0001-create-install-dir.patch
@@ -0,0 +1,24 @@
+From b44f99b7ab158f3e0cf3a2344fcc58d90982378c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 27 May 2010 09:31:03 +0000
+Subject: [PATCH] create install dir
+
+---
+ konference/Makefile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/konference/Makefile b/konference/Makefile
+index 9cc2201..e0901df 100644
+--- a/konference/Makefile
++++ b/konference/Makefile
+@@ -158,6 +158,7 @@ vad_test: vad_test.o libspeex/preprocess.o libspeex/misc.o libspeex/smallft.o
+ $(CC) $(PROFILE) -o $@ $^ -lm
+
+ install:
++ $(INSTALL) -d $(INSTALL_MODULES_DIR)
+ $(INSTALL) -m 755 $(TARGET) $(INSTALL_MODULES_DIR)
+
+
+--
+1.7.1
+
diff --git a/testing/asterisk-audio-konf/APKBUILD b/testing/asterisk-audio-konf/APKBUILD
new file mode 100644
index 0000000000..d10dcbc91e
--- /dev/null
+++ b/testing/asterisk-audio-konf/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asterisk-audio-konf
+_basever=0
+_gitver=100527
+pkgver=${_basever}_git${_gitver}
+pkgrel=0
+pkgdesc="A fork of AppKonference focused entirely on audio conferencing"
+url="http://github.com/jthomerson/AsteriskAudioKonf/"
+license="GPL"
+depends=
+makedepends="asterisk-dev"
+install=
+subpackages=
+_snapfile="$pkgname-$pkgver.tar.bz2"
+source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
+ 0001-create-install-dir.patch
+ "
+
+_gitver=100527
+_giturl="git://github.com/jthomerson/AsteriskAudioKonf.git"
+
+
+_builddir="$srcdir"/$pkgname/konference
+
+
+snapshot() {
+ _gitver=$(date +%y%m%d)
+ pkgver=${_basever}_git$_gitver
+
+ if [ -d "$SRCDEST"/$pkgname ]; then
+ cd "$SRCDEST"/$pkgname
+ git pull --rebase || return 1
+ else
+ cd "$SRCDEST"
+ git clone $_giturl $pkgname
+ fi
+ cd "$SRCDEST"
+ tar -jcf $_snapfile $pkgname
+
+ pkgrel=0
+ sed -i -e "s/^_gitver=.*/_gitver=${_gitver}/" \
+ -e "s/^pkgrel=.*/pkgrel=$pkgrel/" \
+ "$startdir"/APKBUILD
+ checksum
+}
+
+prepare() {
+ cd "$_builddir"/..
+ for i in "$srcdir"/*.patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_PREFIX="$pkgdir" install
+}
+
+md5sums="4e81c731d4b4bd258cd426b5d5dfcdc0 asterisk-audio-konf-0_git100527.tar.bz2
+822df062f4f0890889e3be382ae90504 0001-create-install-dir.patch"