aboutsummaryrefslogtreecommitdiffstats
path: root/testing/asterisk-chan-dongle
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-11 15:31:09 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-11 15:33:21 +0200
commit49a24c0f73e353c3677f6b071c721e3566798e61 (patch)
tree1b1423c2ef4f1b033bca171d9fd9f3d8892aa70d /testing/asterisk-chan-dongle
parentfb354bedba8f137e455e988f966a375cbad2ddbf (diff)
downloadaports-49a24c0f73e353c3677f6b071c721e3566798e61.tar.bz2
aports-49a24c0f73e353c3677f6b071c721e3566798e61.tar.xz
testing/asterisk-chan-dongle: moved from unmaintained
and fixed to build with asterisk 14
Diffstat (limited to 'testing/asterisk-chan-dongle')
-rw-r--r--testing/asterisk-chan-dongle/APKBUILD49
-rw-r--r--testing/asterisk-chan-dongle/asterisk-14.patch35
2 files changed, 84 insertions, 0 deletions
diff --git a/testing/asterisk-chan-dongle/APKBUILD b/testing/asterisk-chan-dongle/APKBUILD
new file mode 100644
index 0000000000..abc7a6db74
--- /dev/null
+++ b/testing/asterisk-chan-dongle/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=asterisk-chan-dongle
+pkgver=1.1.20160925
+_commitid=e3bce3c1d43cec1e4f8e548b4d3880e289747b24
+pkgrel=0
+pkgdesc="GSM modem dongle channel driver"
+url="https://github.com/oleg-krv/asterisk-chan-dongle/"
+arch="all"
+license="GPL2"
+depends="asterisk"
+depends_dev=""
+makedepends="$depends_dev asterisk-dev automake autoconf"
+install=""
+subpackages=""
+provides="asterisk-dongle=$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/oleg-krv/asterisk-chan-dongle/archive/$_commitid.tar.gz
+ asterisk-14.patch
+ "
+
+builddir="$srcdir/$pkgname-$_commitid"
+
+prepare() {
+ default_prepare || return 1
+ cd "$builddir"
+ # automake will return error due to Makefile.am missing
+ # the project autoconfigury foo is old and ships Makefile.in directly
+ aclocal && autoconf && automake -a || true
+}
+
+build() {
+ cd "$builddir"
+ ./configure || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/lib/asterisk/modules "$pkgdir"/etc/asterisk
+ install -m644 etc/dongle.conf "$pkgdir"/etc/asterisk/dongle.conf.sample
+ install -m755 chan_dongle.so "$pkgdir"/usr/lib/asterisk/modules
+}
+
+md5sums="fa96fbcba75f53865d46d8327d21a6c0 asterisk-chan-dongle-1.1.20160925.tar.gz
+bbfb2435082d4284221054c9eadc0c16 asterisk-14.patch"
+sha256sums="50824b72a61ffb062ee0ae49d86a635c846202030223edc960c4fd853aa94187 asterisk-chan-dongle-1.1.20160925.tar.gz
+f21b0c5be6c50ae9dfe81302631a9c8d6ad31f301817f457b13a2c8297f574de asterisk-14.patch"
+sha512sums="2cbd134c284f5a86b0443f459997d4965300920dbcadaf5afbc95cdf5c76e5c0e5b047def1cc590a10b4f8a8fe39575950dafa75afaa52c79e32644eb97bc95a asterisk-chan-dongle-1.1.20160925.tar.gz
+de6c453f8482d9a0c4a77c607efbf058d80342d74bb1053f6f3a18d2e3b79c8fc643f7cdedcdfda414227ecc8ecd05b4cee70a260811dc75128a493b9a772c57 asterisk-14.patch"
diff --git a/testing/asterisk-chan-dongle/asterisk-14.patch b/testing/asterisk-chan-dongle/asterisk-14.patch
new file mode 100644
index 0000000000..49f20b765e
--- /dev/null
+++ b/testing/asterisk-chan-dongle/asterisk-14.patch
@@ -0,0 +1,35 @@
+diff -ru asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/Makefile.in asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/Makefile.in
+--- asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/Makefile.in 2016-10-02 17:35:30.000000000 +0300
++++ asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/Makefile.in 2016-11-11 15:29:54.789991216 +0200
+@@ -37,7 +37,7 @@
+ INSTALL = @INSTALL@
+ CHMOD = chmod
+
+-DEFS = -DASTERISK_VERSION_NUM=130000
++DEFS = -DASTERISK_VERSION_NUM=130000 -DAST_MODULE_SELF_SYM=self_module
+ CFLAGS = @CFLAGS@ -I$(srcdir) @CPPFLAGS@ $(DEFS) @DEFS@ @AC_CFLAGS@
+ LDFLAGS = @LDFLAGS@
+ SOLINK = @SOLINK@
+diff -ru asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/chan_dongle.c asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/chan_dongle.c
+--- asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24.orig/chan_dongle.c 2016-10-02 17:35:30.000000000 +0300
++++ asterisk-chan-dongle-e3bce3c1d43cec1e4f8e548b4d3880e289747b24/chan_dongle.c 2016-11-11 15:28:51.832489663 +0200
+@@ -39,10 +39,7 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-
+ #include <asterisk.h>
+-ASTERISK_FILE_VERSION(__FILE__, "$Rev: " PACKAGE_REVISION " $")
+-
+ #include <asterisk/ast_version.h>
+ #include <asterisk/stringfields.h> /* AST_DECLARE_STRING_FIELDS for asterisk/manager.h */
+ #include <asterisk/manager.h>
+@@ -1793,8 +1790,3 @@
+ );
+
+ //AST_MODULE_INFO_STANDARD (ASTERISK_GPL_KEY, MODULE_DESCRIPTION);
+-
+-EXPORT_DEF struct ast_module* self_module()
+-{
+- return ast_module_info->self;
+-}