aboutsummaryrefslogtreecommitdiffstats
path: root/testing/asterisk/ASTERISK-20362.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-09-05 11:50:40 +0300
committerTimo Teräs <timo.teras@iki.fi>2012-09-05 11:53:13 +0300
commite41af81a83fd767c98c8c5bdba7def5da868163b (patch)
tree7751b089cbb2e4473c2c5193b06799f2f99b364c /testing/asterisk/ASTERISK-20362.patch
parentf5ea352121c614e1abdd86e67ba9c8c3827eb653 (diff)
downloadaports-e41af81a83fd767c98c8c5bdba7def5da868163b.tar.bz2
aports-e41af81a83fd767c98c8c5bdba7def5da868163b.tar.xz
testing/asterisk: fork main/asterisk and upgrade to 11.0.0-beta1
* remove patches upstreamed ASTERISK-18977 and 900-tryinclude.patch * add ASTERISK-20362 required to fix parallel compile issues * rebase the ConfBridge 'deaf participant' patch ASTERISK-19109
Diffstat (limited to 'testing/asterisk/ASTERISK-20362.patch')
-rw-r--r--testing/asterisk/ASTERISK-20362.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/asterisk/ASTERISK-20362.patch b/testing/asterisk/ASTERISK-20362.patch
new file mode 100644
index 0000000000..a64489784d
--- /dev/null
+++ b/testing/asterisk/ASTERISK-20362.patch
@@ -0,0 +1,30 @@
+diff --git a/res/Makefile b/res/Makefile
+index bfbca76..c2ad23b 100644
+--- a/res/Makefile
++++ b/res/Makefile
+@@ -67,17 +67,20 @@ endif
+ ael/pval.o: ael/pval.c
+
+ clean::
++ ${MAKE} -C pjproject clean
+ rm -f snmp/*.o snmp/*.i ael/*.o ael/*.i ais/*.o ais/*.i
+
+ pjproject/build.mak:
+ cd pjproject && ./configure AR="" CFLAGS=-fPIC --disable-floating-point --disable-sound --disable-oss --disable-speex-aec --disable-l16-codec --disable-gsm-codec --disable-g722-codec --disable-g7221-codec --disable-speex-codec --disable-ilbc-codec --disable-g711-codec
+
+-include pjproject/build.mak
++pjproject.stamp: pjproject/build.mak
++ ${MAKE} -j1 -C pjproject dep
++ ${MAKE} -j1 -C pjproject
++ touch pjproject.stamp
+
+-res_rtp_asterisk.o: pjproject/build.mak $(PJ_LIB_FILES)
++-include pjproject/build.mak
++
++res_rtp_asterisk.o: pjproject.stamp
+ res_rtp_asterisk.o: _ASTCFLAGS+=$(PJ_CFLAGS)
+ res_rtp_asterisk.so: _ASTLDFLAGS+=$(PJ_LDFLAGS)
+ res_rtp_asterisk.so: LIBS+=$(PJ_LDLIBS)
+-
+-$(PJ_LIB_FILES):
+- cd pjproject && make dep && make