aboutsummaryrefslogtreecommitdiffstats
path: root/testing/audiofile/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-24 16:05:45 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 13:49:06 -0300
commit8b4c25dc7d713f05cedad6b9e852039aeb215190 (patch)
tree31071f930536b971be18ebd10afb5014c2f2f4d1 /testing/audiofile/APKBUILD
parent1bdc726014e8c6bebf76007d4b8b47a555947f70 (diff)
downloadaports-8b4c25dc7d713f05cedad6b9e852039aeb215190.tar.bz2
aports-8b4c25dc7d713f05cedad6b9e852039aeb215190.tar.xz
testing/audiofile: new aport
Diffstat (limited to 'testing/audiofile/APKBUILD')
-rw-r--r--testing/audiofile/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/audiofile/APKBUILD b/testing/audiofile/APKBUILD
new file mode 100644
index 0000000000..8add493025
--- /dev/null
+++ b/testing/audiofile/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=audiofile
+pkgver=0.3.6
+pkgrel=0
+arch="all"
+url="https://audiofile.68k.org/"
+pkgdesc="Silicon Graphics Audio File Library"
+license="LGPL-2.1-or-later"
+makedepends="linux-headers alsa-lib-dev"
+source="https://audiofile.68k.org/$pkgname-$pkgver.tar.gz
+ gcc8-build-fixes.patch"
+subpackages="$pkgname-static $pkgname-dev $pkgname-libs $pkgname-doc"
+
+build() {
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="f9a1182d93e405c21eba79c5cc40962347bff13f1b3b732d9a396e3d1675297515188bd6eb43033aaa00e9bde74ff4628c1614462456529cabba464f03c1d5fa audiofile-0.3.6.tar.gz
+60837bcc9aa53d546708210e87a4f24db56c8a4b0c6896c8e39e0d213aafa15f59a65a60726e6abbf16681fc1fa6ca59cf1748a63caf5ff2652d55f10f62a976 gcc8-build-fixes.patch"