aboutsummaryrefslogtreecommitdiffstats
path: root/testing/aufs-util/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-18 07:50:19 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-18 07:53:02 -0300
commit4638928b779efbfe274248d2d52f44e275c52957 (patch)
tree80ba08aea12564cac3e54a84f79d751631934885 /testing/aufs-util/APKBUILD
parentdf5167a5ac6280b82c94e22e18ee9da744e90c68 (diff)
downloadaports-4638928b779efbfe274248d2d52f44e275c52957.tar.bz2
aports-4638928b779efbfe274248d2d52f44e275c52957.tar.xz
testing/aufs-utils: new aport
utils for aufs
Diffstat (limited to 'testing/aufs-util/APKBUILD')
-rw-r--r--testing/aufs-util/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/aufs-util/APKBUILD b/testing/aufs-util/APKBUILD
new file mode 100644
index 0000000000..3ce5d890eb
--- /dev/null
+++ b/testing/aufs-util/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinleinux.org>
+pkgname=aufs-util
+pkgver=20161219
+pkgrel=0
+pkgdesc="Utilities for aufs"
+url="http://aufs.sourceforge.net/"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dev.alpinelinux.org/archive/aufs-util/aufs-util-$pkgver.tar.gz
+ 0001-implement-glibc-compatible-nftw-if-libc-does-not-pro.patch
+ 0002-add-aufs_type.h-from-linux-header.patch
+ 0003-make-install-compatible-with-busybox-install.patch
+ "
+
+builddir="$srcdir/aufs-utils"
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2bed79a7f63a411cd8b1642886276cbc aufs-util-20161219.tar.gz
+7ef61437ca8a9ff6efb72fe1f240fec9 0001-implement-glibc-compatible-nftw-if-libc-does-not-pro.patch
+38333696df22393b6c2883ec9f334c91 0002-add-aufs_type.h-from-linux-header.patch
+1dd84fb82b400bcf53e10a0274aaeee3 0003-make-install-compatible-with-busybox-install.patch"
+sha256sums="b3419356904f2dad5af7938cd16fc860bd0646c4b05d70938d7de7047de11e09 aufs-util-20161219.tar.gz
+4f613e4e00c59a241a1aef3c85a9f4e4d609b8727f00e3ff62c0f7cb2c114034 0001-implement-glibc-compatible-nftw-if-libc-does-not-pro.patch
+8a440f1f129457bf245328ca69bc083333f229df7258fb81f0b2abdc0ac4b5f8 0002-add-aufs_type.h-from-linux-header.patch
+3fbd6320de72b65f6ddbf760bbe1fcdec78ce0a097e4febea9962c72a5d8a10b 0003-make-install-compatible-with-busybox-install.patch"
+sha512sums="345ef1643191a6de35eb3036ce41b0ea0725fd2195d4d15dcc904b449e8159fad9a9e3676f7300d624c39403bf4380c7b2f58f2133f9cbcc82be3ceb4097c877 aufs-util-20161219.tar.gz
+156ffb064b90abb1a035f8fcd9db20c6b0ee6ce7f4d9aa2029549d32d93edce0ac59f9a4ae110e9a0ca088af6e360574055af0f320ee5552648d5abaa8b93211 0001-implement-glibc-compatible-nftw-if-libc-does-not-pro.patch
+4481a470ec029b3af5da5f69023ab62f49a889677c828944a4f3dc0802fe163f5ac5c55576e53f0cd656e92d7e503dd6e874184e22e9ff3651aa81073e6161d6 0002-add-aufs_type.h-from-linux-header.patch
+f9d877de3bb93e4b874476ee956f3bfb26b73ac00eecf52b9a5ffabae19b2085abb7e1647db4a7a459d0b0efc59f1e0282ba1407a1202cf937ed52781ff661fa 0003-make-install-compatible-with-busybox-install.patch"