aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ausweisapp2
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2020-01-15 17:16:38 +0100
committerAndré Klitzing <aklitzing@gmail.com>2020-01-15 17:27:19 +0100
commit313fffd7875542f30a4aa9313e90ee1d7c3651af (patch)
tree70d95c7d9fc53d039216f903be46072decddb1be /testing/ausweisapp2
parente32c9ca462618b2cc1f11f9939c91cf1cbd7815c (diff)
downloadaports-313fffd7875542f30a4aa9313e90ee1d7c3651af.tar.bz2
aports-313fffd7875542f30a4aa9313e90ee1d7c3651af.tar.xz
testing/ausweisapp2: upgrade to 1.20.0
Diffstat (limited to 'testing/ausweisapp2')
-rw-r--r--testing/ausweisapp2/0001-Disable-auto-updater.patch52
-rw-r--r--testing/ausweisapp2/0002-Disable-Qt-Quick.patch41
-rw-r--r--testing/ausweisapp2/0003-Fix-path-for-application-icon.patch21
-rw-r--r--testing/ausweisapp2/0004-Fix-path-for-configuration-file.patch21
-rw-r--r--testing/ausweisapp2/0005-Fix-path-for-resource-file.patch30
-rw-r--r--testing/ausweisapp2/0006-Fix-path-for-translation-files.patch21
-rw-r--r--testing/ausweisapp2/APKBUILD38
7 files changed, 10 insertions, 214 deletions
diff --git a/testing/ausweisapp2/0001-Disable-auto-updater.patch b/testing/ausweisapp2/0001-Disable-auto-updater.patch
deleted file mode 100644
index 16b4245655..0000000000
--- a/testing/ausweisapp2/0001-Disable-auto-updater.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:17:07 +0100
-Subject: Disable auto updater
-
----
- src/settings/GeneralSettings.cpp | 2 +-
- src/ui/widget/GeneralSettingsWidget.ui | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/settings/GeneralSettings.cpp b/src/settings/GeneralSettings.cpp
-index d22943d..67af9ef 100644
---- a/src/settings/GeneralSettings.cpp
-+++ b/src/settings/GeneralSettings.cpp
-@@ -362,7 +362,7 @@ bool GeneralSettings::isAutoUpdateCheck() const
- mStoreGeneral->remove(SETTINGS_NAME_AUTO());
- }
-
--#if defined(Q_OS_ANDROID) || defined(Q_OS_IOS)
-+#if defined(Q_OS_ANDROID) || defined(Q_OS_IOS) || defined(Q_OS_LINUX)
- return mStoreCommon->value(SETTINGS_NAME_AUTO(), false).toBool();
-
- #else
-diff --git a/src/ui/widget/GeneralSettingsWidget.ui b/src/ui/widget/GeneralSettingsWidget.ui
-index 90f4863..b0b2e2d 100644
---- a/src/ui/widget/GeneralSettingsWidget.ui
-+++ b/src/ui/widget/GeneralSettingsWidget.ui
-@@ -45,7 +45,7 @@
- <item row="0" column="1">
- <widget class="QCheckBox" name="regularlyUpdateCheckBox">
- <property name="enabled">
-- <bool>true</bool>
-+ <bool>false</bool>
- </property>
- <property name="accessibleName">
- <string>check software update on program start</string>
-@@ -54,14 +54,14 @@
- <string>check on program start</string>
- </property>
- <property name="checked">
-- <bool>true</bool>
-+ <bool>false</bool>
- </property>
- </widget>
- </item>
- <item row="1" column="1">
- <widget class="QPushButton" name="updateCheckButton">
- <property name="enabled">
-- <bool>true</bool>
-+ <bool>false</bool>
- </property>
- <property name="sizePolicy">
- <sizepolicy hsizetype="Fixed" vsizetype="Fixed">
diff --git a/testing/ausweisapp2/0002-Disable-Qt-Quick.patch b/testing/ausweisapp2/0002-Disable-Qt-Quick.patch
deleted file mode 100644
index 6db81abfa4..0000000000
--- a/testing/ausweisapp2/0002-Disable-Qt-Quick.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:17:53 +0100
-Subject: Disable Qt Quick
-
----
- cmake/Libraries.cmake | 6 ------
- src/main.cpp | 4 ----
- 2 files changed, 10 deletions(-)
-
-diff --git a/cmake/Libraries.cmake b/cmake/Libraries.cmake
-index fed98dc..1d92f6e 100644
---- a/cmake/Libraries.cmake
-+++ b/cmake/Libraries.cmake
-@@ -13,12 +13,6 @@ FIND_PACKAGE(Qt5Svg ${MIN_QT_VERSION} REQUIRED)
- FIND_PACKAGE(Qt5LinguistTools ${MIN_QT_VERSION} REQUIRED)
- FIND_PACKAGE(Qt5WebSockets ${MIN_QT_VERSION} REQUIRED)
-
--IF(NOT ANDROID_BUILD_AAR)
-- FIND_PACKAGE(Qt5Qml ${MIN_QT_VERSION} REQUIRED)
-- FIND_PACKAGE(Qt5Quick ${MIN_QT_VERSION} REQUIRED)
-- FIND_PACKAGE(Qt5QuickControls2 ${MIN_QT_VERSION} REQUIRED)
--ENDIF()
--
- IF(DESKTOP)
- FIND_PACKAGE(Qt5Widgets ${MIN_QT_VERSION} REQUIRED)
-
-diff --git a/src/main.cpp b/src/main.cpp
-index 54c9c78..35da465 100644
---- a/src/main.cpp
-+++ b/src/main.cpp
-@@ -97,10 +97,6 @@ Q_IMPORT_PLUGIN(UIPlugInWidgets)
- Q_IMPORT_PLUGIN(UIPlugInAidl)
- #endif
-
--#ifndef ANDROID_BUILD_AAR
--Q_IMPORT_PLUGIN(UIPlugInQml)
--#endif
--
- Q_IMPORT_PLUGIN(UIPlugInJson)
- Q_IMPORT_PLUGIN(UIPlugInWebSocket)
-
diff --git a/testing/ausweisapp2/0003-Fix-path-for-application-icon.patch b/testing/ausweisapp2/0003-Fix-path-for-application-icon.patch
deleted file mode 100644
index b3c0d1d693..0000000000
--- a/testing/ausweisapp2/0003-Fix-path-for-application-icon.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:18:19 +0100
-Subject: Fix path for application icon
-
----
- resources/packaging/linux/AusweisApp2.desktop.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/resources/packaging/linux/AusweisApp2.desktop.in b/resources/packaging/linux/AusweisApp2.desktop.in
-index 8a01027..824d01b 100644
---- a/resources/packaging/linux/AusweisApp2.desktop.in
-+++ b/resources/packaging/linux/AusweisApp2.desktop.in
-@@ -2,7 +2,7 @@
- Version=1.0
- Type=Application
- Exec=@CMAKE_INSTALL_PREFIX@/bin/AusweisApp2
--Icon=AusweisApp2
-+Icon=@CMAKE_INSTALL_PREFIX@/share/AusweisApp2/npa.png
- StartupNotify=true
- Terminal=false
- Categories=Utility;Accessibility;
diff --git a/testing/ausweisapp2/0004-Fix-path-for-configuration-file.patch b/testing/ausweisapp2/0004-Fix-path-for-configuration-file.patch
deleted file mode 100644
index 0c135d6fee..0000000000
--- a/testing/ausweisapp2/0004-Fix-path-for-configuration-file.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:18:55 +0100
-Subject: Fix path for configuration file
-
----
- src/secure_storage/SecureStorage.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/secure_storage/SecureStorage.cpp b/src/secure_storage/SecureStorage.cpp
-index 67a5823..ee4c4a7 100644
---- a/src/secure_storage/SecureStorage.cpp
-+++ b/src/secure_storage/SecureStorage.cpp
-@@ -95,7 +95,7 @@ SecureStorage& SecureStorage::getInstance()
-
- void SecureStorage::load()
- {
-- const auto& path = FileDestination::getPath(QStringLiteral("config.json"));
-+ const auto& path = QStringLiteral("/usr/share/AusweisApp2/config.json");
-
- if (!QFile::exists(path))
- {
diff --git a/testing/ausweisapp2/0005-Fix-path-for-resource-file.patch b/testing/ausweisapp2/0005-Fix-path-for-resource-file.patch
deleted file mode 100644
index 6af0327a76..0000000000
--- a/testing/ausweisapp2/0005-Fix-path-for-resource-file.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:30:19 +0100
-Subject: Fix path for resource file
-
----
- src/global/ResourceLoader.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/global/ResourceLoader.cpp b/src/global/ResourceLoader.cpp
-index 76b71c2..a41f813 100644
---- a/src/global/ResourceLoader.cpp
-+++ b/src/global/ResourceLoader.cpp
-@@ -19,7 +19,7 @@ defineSingleton(ResourceLoader)
- ResourceLoader::ResourceLoader()
- : mFilenames(
- {
-- QStringLiteral("AusweisApp2.rcc")
-+ QStringLiteral("/usr/share/AusweisApp2/AusweisApp2.rcc")
- })
- , mLoadedResources()
- {
-@@ -42,7 +42,7 @@ void ResourceLoader::init()
- {
- for (const auto& file : mFilenames)
- {
-- QString path = FileDestination::getPath(file);
-+ QString path = file;
-
- #ifndef QT_NO_DEBUG
- const auto& filePathFromTestDir = QCoreApplication::applicationDirPath() + QStringLiteral("/../../src/") + file;
diff --git a/testing/ausweisapp2/0006-Fix-path-for-translation-files.patch b/testing/ausweisapp2/0006-Fix-path-for-translation-files.patch
deleted file mode 100644
index a6b48c75cd..0000000000
--- a/testing/ausweisapp2/0006-Fix-path-for-translation-files.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
-Date: Sat, 28 Dec 2019 15:30:47 +0100
-Subject: Fix path for translation files
-
----
- src/global/LanguageLoader.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/global/LanguageLoader.cpp b/src/global/LanguageLoader.cpp
-index 62131ad..1082719 100644
---- a/src/global/LanguageLoader.cpp
-+++ b/src/global/LanguageLoader.cpp
-@@ -23,7 +23,7 @@ const QLocale::Language LanguageLoader::mFallbackLanguage = QLocale::Language::E
- QLocale LanguageLoader::mDefaultLanguage = QLocale::system();
-
- LanguageLoader::LanguageLoader()
-- : mPath(FileDestination::getPath(QStringLiteral("translations")))
-+ : mPath(QStringLiteral("/usr/share/AusweisApp2/translations"))
- , mTranslatorList()
- , mComponentList(
- {
diff --git a/testing/ausweisapp2/APKBUILD b/testing/ausweisapp2/APKBUILD
index d087750d19..db648a5c6a 100644
--- a/testing/ausweisapp2/APKBUILD
+++ b/testing/ausweisapp2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=ausweisapp2
-pkgver=1.18.2
+pkgver=1.20.0
pkgrel=0
pkgdesc="Official authentication app for German ID card and residence permit"
url="https://www.ausweisapp.bund.de/"
@@ -9,39 +9,21 @@ arch="all"
license="EUPL-1.2"
depends="pcsc-lite pcsc-cyberjack ccid acsccid"
makedepends="cmake pkgconf pcsc-lite-dev http-parser-dev openssl-dev
- qt5-qtbase-dev qt5-qtsvg-dev qt5-qtwebsockets-dev qt5-qttools-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Governikus/AusweisApp2/archive/$pkgver.tar.gz
- 0001-Disable-auto-updater.patch
- 0002-Disable-Qt-Quick.patch
- 0003-Fix-path-for-application-icon.patch
- 0004-Fix-path-for-configuration-file.patch
- 0005-Fix-path-for-resource-file.patch
- 0006-Fix-path-for-translation-files.patch
- "
+ qt5-qtbase-dev qt5-qtsvg-dev qt5-qtwebsockets-dev qt5-qttools-dev
+ qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev"
+source="https://github.com/Governikus/AusweisApp2/releases/download/$pkgver/AusweisApp2-$pkgver.tar.gz"
options="!check" # no upstream tests in release build
builddir="$srcdir/AusweisApp2-$pkgver"
build() {
- mkdir -p build && cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ mkdir -p build && cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
- mkdir $pkgdir/usr/share/AusweisApp2
- mv $pkgdir/usr/bin/AusweisApp2.rcc $pkgdir/usr/share/AusweisApp2
- mv $pkgdir/usr/bin/config.json $pkgdir/usr/share/AusweisApp2
- mv $pkgdir/usr/translations/ausweisapp2_de.qm $pkgdir/usr/share/AusweisApp2
- install -m 644 $builddir/resources/images/npa_docs.png $pkgdir/usr/share/AusweisApp2/npa.png
- rm -rf $pkgdir/usr/translations
+ cd build
+ make DESTDIR="$pkgdir" install
}
-sha512sums="2cc0fc13c281879f30d98d0fc5d440debae4067f322d03a149dbf73b8e4ddb07a39f55417b5304445cc539cfc3a6751067331a17062aa1113421040170d87fa9 ausweisapp2-1.18.2.tar.gz
-2c3a093137bc563adc9571c05c7dccc541c1a445133ab9e4fe23a248de7e3a590c5150f6541c8f68374bb69e0a11e4ef4931fb7c2774ab003a5edaf1cfe1f845 0001-Disable-auto-updater.patch
-27a7e3151160cdcbc8fda3a9f8e83c469fee7054bc04fe0734f2cd1988e53a97cb8b92720ee7105a7ec53f4daccb3a2bb66df53455ce3ad401f26ea9653965fa 0002-Disable-Qt-Quick.patch
-10f2f440fe52a55a99a2729a437e8b97203dca9fe41b2b556688d2b17362f5a80ef00387891d6f1420778b0a906321fb6c46d16778f47177117cb8145b0e5ff2 0003-Fix-path-for-application-icon.patch
-885ad615d3f5efd60e8d763cb211da26b00fa3e05826b97c6c12478ad9ec9a5b97de6f543f57f223d30c4b29fd3c4b598f0a966a6dab3d28274fc0f7a4029475 0004-Fix-path-for-configuration-file.patch
-669df4af1eda61b97ca5864d4a2313c3eedfa145db6b74b5758caf533054fef8385519fb6c0d04af01a6ba60079753ed824632e0f528244258aaa9170cd40d5f 0005-Fix-path-for-resource-file.patch
-498e755ca2ea3768517486d7b488683a01c63eda1bfc6bcab5c1ae234876d84da9d089a132c78e8b1dfdcfa88c5bdad0c178138e3875da2cca4c86077839a4ad 0006-Fix-path-for-translation-files.patch"
+sha512sums="9fe83d59a02e8ae89dae9264a94b3d1bd943b6d4843dd8a833e9bb65a0d98c6d78f7c7b69f5cae74f013b84bf580228e1a9805f8deb8fcfc33f002f73e61d4ee AusweisApp2-1.20.0.tar.gz"