aboutsummaryrefslogtreecommitdiffstats
path: root/testing/autossh
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-18 20:46:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:24:04 +0200
commit5c9f3ca3e307be53b45beeed2ce1626f38008625 (patch)
tree919836fe454e953f46685adf8228b0401280d4b6 /testing/autossh
parent6a00a953ba02bab6440a2c784e7db37c6eaeace1 (diff)
downloadaports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.bz2
aports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.xz
testing/[various]: move to community
albatross-themes apk-post-messages autossh bitcoin btrbk entr ffmpegthumbnailer firejail firetools fwsnort gnome-colors imapsync inetutils-syslogd inotify-tools-inc isync junit ktsuss letsencrypt-nosudo libmbim libndp libqmi libteam mini-sendmail modemmanager namecoin networkmanager nginx-naxsi numix-themes nxapi opencl-headers opencl-icd-loader opus-tools perl-authen-ntlm perl-bit-vector perl-data-uniqid perl-file-copy-recursive perl-getopt-argvfile perl-io-tee perl-iptables-chainmgr perl-iptables-parse perl-module-scandeps perl-par-dist perl-par-packer perl-par perl-uri-escape psad py-crcmod py-graphviz py-lz4 py-opencl py-opengl-accelerate runit secpwgen secure-delete socklog spacefm tinyssh udevil virt-viewer virtualbricks whois wrk xpra zram-init
Diffstat (limited to 'testing/autossh')
-rw-r--r--testing/autossh/APKBUILD66
-rw-r--r--testing/autossh/README.alpine34
2 files changed, 0 insertions, 100 deletions
diff --git a/testing/autossh/APKBUILD b/testing/autossh/APKBUILD
deleted file mode 100644
index ef27bd3518..0000000000
--- a/testing/autossh/APKBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=autossh
-pkgver=1.4e
-pkgrel=0
-pkgdesc="Automatically restart SSH sessions and tunnels"
-url="http://www.harding.motd.ca/autossh/"
-arch="all"
-license="BSD"
-depends="openssh-client"
-depends_dev=""
-makedepends="$depends_dev"
-subpackages="$pkgname-doc"
-source="http://www.harding.motd.ca/autossh/autossh-$pkgver.tgz
- README.alpine
- "
-
-_builddir="$srcdir"/autossh-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -D -m755 autossh \
- "$pkgdir"/usr/bin/autossh || return 1
- install -D -m644 CHANGES \
- "$pkgdir"/usr/share/doc/autossh/CHANGES || return 1
- install -D -m644 README \
- "$pkgdir"/usr/share/doc/autossh/README || return 1
- install -D -m644 autossh.host \
- "$pkgdir"/usr/share/autossh/examples/autossh.host || return 1
- install -D -m644 rscreen \
- "$pkgdir"/usr/share/autossh/examples/rscreen || return 1
- install -D -m644 autossh.1 \
- "$pkgdir"/usr/share/man/man1/autossh.1 || return 1
- install -Dm644 "$srcdir"/README.alpine \
- "$pkgdir"/usr/share/doc/$pkgname/README.alpine || return 1
-}
-
-md5sums="f86684b96e99d22b2e9d35dc63b0aa29 autossh-1.4e.tgz
-fb31542bb76c90a8286fdf8eca402d1e README.alpine"
-sha256sums="9e8e10a59d7619176f4b986e256f776097a364d1be012781ea52e08d04679156 autossh-1.4e.tgz
-7e1a64e013743e94aa9477968d1a9dc9ca71f11b45a0530088d0c03b19f474cb README.alpine"
-sha512sums="2f71403ee005103c6a3e2e669f6b26153161c95c8dacd3e73d61673461b3512348636877760d911341771e744c0a682b107df4ac48621661ff36a9fc0191f2fb autossh-1.4e.tgz
-25ec2d17c5b93d8c3f5b41f1bb2671432e8d29081621fe58ff8de4c20171b7447459272a27264440a947ef5867ed15bbaaea8ea7ec02783956055e0ee8e31128 README.alpine"
diff --git a/testing/autossh/README.alpine b/testing/autossh/README.alpine
deleted file mode 100644
index d7013c3ad8..0000000000
--- a/testing/autossh/README.alpine
+++ /dev/null
@@ -1,34 +0,0 @@
-Example: Connecting to remote postgresql
-========================================
-
-(1) On both the local & remote hosts:
-
-adduser -s /bin/false autossh <with blank passwords>
--------------------------------------------------------------------
-
-(2) On the local client create an SSH key with an empty password:
-
-su -s /bin/sh autossh
-echo 'y' |ssh-keygen -t ed25519 -N ''
--------------------------------------------------------------------
-
-(3) If using runit for service supervision < /etc/sv/autossh/run >:
-
--------------------------------------------------------------------
-#!/bin/sh
-exec 2>&1
-su -s /bin/sh autossh -c \
-'autossh -M 0 -o "ServerAliveInterval 60" -o "ServerAliveCountMax 3" -L 1234:localhost:1234 -N -l autossh remote.ip.addr'
--------------------------------------------------------------------------------------------------------------------------
-ln -s /etc/sv/autossh /etc/service/autossh
--------------------------------------------------------------------------------
-** if running autossh in a script without using runit add -f to ssh options **|
--------------------------------------------------------------------------------
-
-(4) Connect with:
-
-psql -h 127.0.0.1 -p 1234 -U username -d database
--------------------------------------------------------------------------------
-openssh-server: works out of the box | ed25519 keys possible
-dropbear: echo "/bin/false" >> /etc/shells | ecdsa keys possible
-tinyssh: port forwarding not yet implemented | ed25519 keys possible