aboutsummaryrefslogtreecommitdiffstats
path: root/testing/awesome
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-02 08:36:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-02 08:38:05 +0000
commit3bdb940681cd951caf28f7ef833f6275ffa34aab (patch)
treec7598c664bd9808718c6bf79d0868218299752be /testing/awesome
parenta1c48718717a2b8db2b8af99f5094dc0a423a828 (diff)
downloadaports-3bdb940681cd951caf28f7ef833f6275ffa34aab.tar.bz2
aports-3bdb940681cd951caf28f7ef833f6275ffa34aab.tar.xz
testing/awesome: build fix for cmake-2.8.4
See: https://awesome.naquadah.org/bugs/index.php?do=details&task_id=869
Diffstat (limited to 'testing/awesome')
-rw-r--r--testing/awesome/APKBUILD13
-rw-r--r--testing/awesome/cmake.patch37
2 files changed, 45 insertions, 5 deletions
diff --git a/testing/awesome/APKBUILD b/testing/awesome/APKBUILD
index 1b64807eb8..43531bf08d 100644
--- a/testing/awesome/APKBUILD
+++ b/testing/awesome/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=awesome
pkgver=3.4.9
-pkgrel=0
+pkgrel=1
pkgdesc="lua-configurable window manager framework"
url="http://awesome.naquadah.org/"
arch="all"
@@ -11,13 +11,15 @@ depends="imagemagick"
makedepends="lua-dev libxcb-dev pango-dev cairo-dev cmake gperf glib-dev imlib2-dev libxdg-basedir-dev libev-dev startup-notification-dev"
install=""
subpackages="$pkgname-doc"
-source="http://awesome.naquadah.org/download/${pkgname}-${pkgver}.tar.bz2"
+source="http://awesome.naquadah.org/download/${pkgname}-${pkgver}.tar.bz2
+ cmake.patch
+ "
_srcdir="${srcdir}/${pkgname}-${pkgver}"
_builddir="${srcdir}/build"
prepare() {
local i
- cd "$_builddir"
+ cd "$_srcdir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -37,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="a3e8f22fb4d17dd1cda90b354be84d6f awesome-3.4.9.tar.bz2"
+md5sums="a3e8f22fb4d17dd1cda90b354be84d6f awesome-3.4.9.tar.bz2
+3382b552d0519c8637c86b2e61f1e052 cmake.patch"
diff --git a/testing/awesome/cmake.patch b/testing/awesome/cmake.patch
new file mode 100644
index 0000000000..c2762374ed
--- /dev/null
+++ b/testing/awesome/cmake.patch
@@ -0,0 +1,37 @@
+commit 8b6adbffead83c9d77c493174d0f5b6a97f2a9e9
+Author: Thomas Moschny <thomas.moschny@gmx.de>
+Date: Mon Feb 21 17:58:04 2011 +0100
+
+ Normalize icon path names (fixes #869).
+
+ The elements in ${icon_sources}, as returned by file(GLOB ...) contain
+ double slashes, could be a bug in cmake. This causes building with
+ cmake 2.8.4 to fail, due to dependency problems lateron.
+
+ This patch works around the issue by normalizing all path names in
+ ${icon_sources} while appending them to ${ALL_ICONS}, thereby removing
+ the double slashes.
+
+ Signed-off-by: Uli Schlachter <psychon@znc.in>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64be9b9..472bec2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,14 +244,15 @@ endif()
+
+ # {{{ Theme icons
+ file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
+
+ foreach(icon ${icon_sources})
+ # Copy all icons to the build dir to simplify the following code.
+ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
+ # relative to ${BUILD_DIR}.
+ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
+ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
+ endforeach()
+
+ macro(a_icon_convert match replacement input)