aboutsummaryrefslogtreecommitdiffstats
path: root/testing/belr
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-02 15:08:06 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-02 15:08:06 +0000
commitbce6c5f52fff5b8d79563b58a539caa48ec67a75 (patch)
tree8affe7bc6cbc6a0ac40f7e529438ca72e4a6d1ce /testing/belr
parent78b5a858feee29a16d6de196c43cb8ba46c5f9a5 (diff)
downloadaports-bce6c5f52fff5b8d79563b58a539caa48ec67a75.tar.bz2
aports-bce6c5f52fff5b8d79563b58a539caa48ec67a75.tar.xz
testing/belr: new aport
Diffstat (limited to 'testing/belr')
-rw-r--r--testing/belr/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/belr/APKBUILD b/testing/belr/APKBUILD
new file mode 100644
index 0000000000..eab6b02d89
--- /dev/null
+++ b/testing/belr/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="belr"
+pkgver="0.1.3"
+_pkgver=${pkgver}-0
+pkgrel=0
+pkgdesc="ABNF Parser"
+url="https://www.linphone.org"
+arch="all"
+license="GPL-3.0-or-later"
+options="!check" # not test available
+makedepends="cmake bctoolbox-dev eudev-dev"
+subpackages="$pkgname-dev"
+source="https://www.linphone.org/releases/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$_pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake \
+ -DENABLE_STRICT=NO \
+ -DENABLE_SHARED=YES \
+ -DENABLE_STATIC=NO .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/lib/cmake/Belr
+ mv "$pkgdir"/usr/share/Belr/cmake/* "$subpkgdir"/usr/lib/cmake/Belr
+}
+
+sha512sums="9ce7a3d1c4de8241b6a6ba10d53483070940e4652577dd6afc63cbf850bd3ab14ff8aba6702a903eba6098cbfbd9be5e57e9690ca45fe2d50ecebf3bccf86e16 belr-0.1.3.tar.gz"