aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bitcoin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-20 13:13:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-20 13:13:28 +0000
commit1351763935e932e23f70a7ecf2cf69a79be5084b (patch)
tree4e1c06057089975c2727b34a6f63b637e76e6a37 /testing/bitcoin
parent22401ec917f3eaa2691eca14141400a86993c5a0 (diff)
downloadaports-1351763935e932e23f70a7ecf2cf69a79be5084b.tar.bz2
aports-1351763935e932e23f70a7ecf2cf69a79be5084b.tar.xz
testing/bitcoin: compile fix
Diffstat (limited to 'testing/bitcoin')
-rw-r--r--testing/bitcoin/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/bitcoin/APKBUILD b/testing/bitcoin/APKBUILD
index 335ddb6836..33738e714d 100644
--- a/testing/bitcoin/APKBUILD
+++ b/testing/bitcoin/APKBUILD
@@ -35,6 +35,10 @@ prepare() {
build() {
cd "$_builddir"
+ # we need to set BOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT after
+ # boost 1.58.0
+ # http://www.boost.org/doc/libs/1_58_0/doc/html/boost/get_idp295310448.html
+ CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1" \
./configure \
--build=$CBUILD \
--host=$CHOST \