aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bluez5
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-15 14:51:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-15 14:51:45 +0000
commit9912975644615cfe9396f999717e67ac50b87c19 (patch)
tree5cd07b37c3afa349177a9c45e465bc944a56751e /testing/bluez5
parentf596c243c56682e416b0de42c95e2b1020f1753e (diff)
downloadaports-9912975644615cfe9396f999717e67ac50b87c19.tar.bz2
aports-9912975644615cfe9396f999717e67ac50b87c19.tar.xz
testing/bluez5: new aport
Tools for the Bluetooth protocol stack http://www.bluez.org/
Diffstat (limited to 'testing/bluez5')
-rw-r--r--testing/bluez5/APKBUILD75
-rw-r--r--testing/bluez5/bluetooth.initd11
-rw-r--r--testing/bluez5/rfcomm.confd5
-rw-r--r--testing/bluez5/rfcomm.initd27
4 files changed, 118 insertions, 0 deletions
diff --git a/testing/bluez5/APKBUILD b/testing/bluez5/APKBUILD
new file mode 100644
index 0000000000..1f072ae77a
--- /dev/null
+++ b/testing/bluez5/APKBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bluez5
+pkgver=5.7
+pkgrel=0
+pkgdesc="Tools for the Bluetooth protocol stack"
+url="http://www.bluez.org/"
+arch="all"
+license="GPL2"
+depends="consolekit dbus"
+replaces="udev"
+makedepends="dbus-dev libusb-compat-dev udev-dev
+ libical-dev readline-dev glib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
+ $pkgname-hid2hci"
+source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.bz2
+ bluetooth.initd
+ rfcomm.initd
+ rfcomm.confd
+ "
+
+_builddir="$srcdir"/bluez-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --disable-systemd \
+ --enable-library \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
+ install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
+ install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
+ install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
+}
+
+libs() {
+ pkgdesc="Libraries for Bluetooth protocol stack"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
+}
+
+cups() {
+ pkgdesc="Bluez backend for CUPS"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
+}
+
+hid2hci() {
+ pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ replaces="bluez"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
+md5sums="eb883ce61753bd3f300a531bcc2af49e bluez-5.7.tar.bz2
+833746cfe1c4f8188a8cd03f157b4a93 bluetooth.initd
+7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
+7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
+sha256sums="8db8b024e3edd897b30290134ad02920ad42f6cb0f93fcd6f7057672a4e28f7d bluez-5.7.tar.bz2
+b637eeb3ddc4143fac2510ff2f3f192f8d853d421d495f063953050838bc13a2 bluetooth.initd
+4430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
+672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
+sha512sums="edce3504708ad5e5717941c668bc285c17c5ccc5dea82881d2e9d25fe266f98294dacf0e79d4ca4a68ffb204c328fef75d4cdab1b4f4750156ccdc5b9662e2a3 bluez-5.7.tar.bz2
+69b4834b07124eef32712a92d20b2ac865cfb48c43ec3895edb270b258189013a82758c3fc76faa12735ba8d04b1e77f95cf1322b1c7332a04c3d9621376936f bluetooth.initd
+8f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
+a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"
diff --git a/testing/bluez5/bluetooth.initd b/testing/bluez5/bluetooth.initd
new file mode 100644
index 0000000000..23426b7c89
--- /dev/null
+++ b/testing/bluez5/bluetooth.initd
@@ -0,0 +1,11 @@
+#!/sbin/runscript
+
+name="Bluetooth"
+command="/usr/lib/bluetooth/bluetoothd"
+
+
+depend() {
+ after coldplug
+ need dbus localmount
+}
+
diff --git a/testing/bluez5/rfcomm.confd b/testing/bluez5/rfcomm.confd
new file mode 100644
index 0000000000..d87acdb282
--- /dev/null
+++ b/testing/bluez5/rfcomm.confd
@@ -0,0 +1,5 @@
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/testing/bluez5/rfcomm.initd b/testing/bluez5/rfcomm.initd
new file mode 100644
index 0000000000..d3b819e1ab
--- /dev/null
+++ b/testing/bluez5/rfcomm.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/rfcomm-init.d,v 1.1 2011/12/31 21:09:18 pacho Exp $
+
+depend() {
+ after coldplug
+ need dbus localmount hostname
+}
+
+start() {
+ if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
+ if [ -f "${RFCOMM_CONFIG}" ]; then
+ ebegin "Starting rfcomm"
+ /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
+ eend $?
+ else
+ ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
+ fi
+ fi
+}
+
+stop() {
+ ebegin "Shutting down rfcomm"
+ /usr/bin/rfcomm release all
+ eend $?
+}