aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bmake/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-12-21 18:49:27 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-12-21 18:50:49 +0100
commitff5117155c530c327ec13a639499dc19e5536ee6 (patch)
treec6e9e0a8ad2bb2cfff73e0961c1f6e1a968536ea /testing/bmake/APKBUILD
parentf751ac10279ad1677402fb5f3635bb4f5f581456 (diff)
downloadaports-ff5117155c530c327ec13a639499dc19e5536ee6.tar.bz2
aports-ff5117155c530c327ec13a639499dc19e5536ee6.tar.xz
testing/bmake: unset MAKEFLAGS globally
It needs to be reset for both the check() and install() function. So we might as well reset it globally. Do include the `-j` flag though to take advantage of parallel builds.
Diffstat (limited to 'testing/bmake/APKBUILD')
-rw-r--r--testing/bmake/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/bmake/APKBUILD b/testing/bmake/APKBUILD
index c204b67014..045473a2bb 100644
--- a/testing/bmake/APKBUILD
+++ b/testing/bmake/APKBUILD
@@ -12,14 +12,16 @@ source="http://www.crufty.net/ftp/pub/sjg/bmake-$pkgver.tar.gz
separate-tests.patch"
builddir="$srcdir/$pkgname"
+# Reset MAKEFLAGS since it might contain options not supported
+# by bmake. This is, for instance, the case on the builders.
+export MAKEFLAGS="-j${JOBS:-1}"
+
build() {
sh ./boot-strap --with-default-sys-path=/usr/share/mk op=build
}
check() {
- # Unset MAKEFLAGS since it might contain options not supported
- # by bmake. This is, for instance, the case on the builders.
- env MAKEFLAGS= sh ./boot-strap op=test
+ sh ./boot-strap op=test
}
package() {