aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bmake
diff options
context:
space:
mode:
authorSteffen Nurpmeso <steffen@sdaoden.eu>2017-10-09 18:47:10 +0200
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 11:38:17 +0000
commitc22de86e479c76ae398d895020c9b42ba65295c2 (patch)
tree204f45097a17dfff61879d6f027911a2f378b0a0 /testing/bmake
parent6d47517c9c44fb63942c9df94b3c9ad13d87b2fc (diff)
downloadaports-c22de86e479c76ae398d895020c9b42ba65295c2.tar.bz2
aports-c22de86e479c76ae398d895020c9b42ba65295c2.tar.xz
testing/bmake: new aport
http://www.crufty.net/help/sjg/bmake.html Portable version of the NetBSD make build tool
Diffstat (limited to 'testing/bmake')
-rw-r--r--testing/bmake/APKBUILD44
-rw-r--r--testing/bmake/install-sh.patch8
-rw-r--r--testing/bmake/sjg.patch59
3 files changed, 111 insertions, 0 deletions
diff --git a/testing/bmake/APKBUILD b/testing/bmake/APKBUILD
new file mode 100644
index 0000000000..66d011ea5a
--- /dev/null
+++ b/testing/bmake/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Steffen Nurpmeso <steffen@sdaoden.eu>
+pkgname=bmake
+pkgver=20180919
+pkgrel=0
+pkgdesc="Portable version of the NetBSD make build tool"
+url="http://www.crufty.net/help/sjg/bmake.html"
+arch="all"
+license="BSD"
+subpackages="$pkgname-doc"
+source="http://www.crufty.net/ftp/pub/sjg/bmake-$pkgver.tar.gz
+ install-sh.patch"
+
+builddir="$srcdir/$pkgname"
+options="!check" # Check automatically performed after build
+
+build() {
+ cd "$builddir"
+ mkdir -p build
+ cd build
+ # Avoid that paths sneak in.
+ PATH=/sbin:/usr/sbin:/bin:/usr/bin
+ C_INCLUDE_PATH=/usr/include
+ LD_LIBRARY_PATH=/lib:/usr/lib
+ LIBRARY_PATH=$LD_LIBRARY_PATH
+ LD_RUN_PATH=$LD_LIBRARY_PATH
+ export PATH C_INCLUDE_PATH LD_LIBRARY_PATH LIBRARY_PATH LD_RUN_PATH
+ sh ../boot-strap --with-default-sys-path=/usr/share/mk
+}
+
+package() {
+ cd "$builddir/build"
+ sh ../boot-strap --prefix=/usr --with-mksrc=/usr/share/mk \
+ --install-destdir="$pkgdir" op=install
+
+ rm -rf "$pkgdir"/usr/share/man/cat1
+ mkdir "$pkgdir"/usr/share/man/man1
+ cp ../bmake.1 "$pkgdir"/usr/share/man/man1/
+ mkdir -p "$pkgdir"/usr/share/licenses/"$pkgname"
+ sed -e 3,69p -e d ../main.c >\
+ "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}
+
+sha512sums="5147513a0fd05b73ccd5ab057bcfd9e0c5d21681a5229d8ea870da7ad72fbd140b4b89245fdb2ef276152d237e478d64923623b99ce7bb85f746b01593d4fd1a bmake-20180919.tar.gz
+0de9022a2991c5ef02c09ab592a3e2d218cd0bbf58e54f21bc7694110f3dd9e4589bf2b3d241fd167fb220b425007863f20e71e141b4f65bf92d305ba94209da install-sh.patch"
diff --git a/testing/bmake/install-sh.patch b/testing/bmake/install-sh.patch
new file mode 100644
index 0000000000..974b5193bb
--- /dev/null
+++ b/testing/bmake/install-sh.patch
@@ -0,0 +1,8 @@
+--- XXX/install-sh.orig
++++ XXX/install-sh
+@@ -1,4 +1,4 @@
+-:
++#!/bin/sh
+ # NAME:
+ # install.sh - portable version of install(1)
+ #
diff --git a/testing/bmake/sjg.patch b/testing/bmake/sjg.patch
new file mode 100644
index 0000000000..11b617b91a
--- /dev/null
+++ b/testing/bmake/sjg.patch
@@ -0,0 +1,59 @@
+From sjg@crufty.net Wed Oct 4 00:46:22 2017
+From: Simon Gerraty <sjg@crufty.net>
+To: Steffen Nurpmeso <steffen@sdaoden.eu>
+Subject: Re: bmake: errors when creating Alpine Linux/Musl package
+MIME-Version: 1.0
+Content-Type: text/plain; charset="us-ascii"
+Content-ID: <24543.1507070779.1@bad.crufty.net>
+Date: Tue, 03 Oct 2017 15:46:19 -0700
+Message-ID: <20363.1507070779@bad.crufty.net>
+Status: RO
+
+> |The warning about __inline being redefined - I would not expect
+> |missing/sys/cdefs.h to be used on a Linux platform - every one I'd used
+> |(not many) has sys/cdefs.h
+
+Not much we can do about that warning.
+Fortunately nothing in bmake uses __inline
+
+For the tcc getopt bit, try running strings on the object
+to see where that Del char is.
+
+For gcc, try the patch below
+
+Index: unit-tests/dotwait.exp
+===================================================================
+RCS file: /volume/cvs/bmake/unit-tests/dotwait.exp,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 dotwait.exp
+--- XXX/unit-tests/dotwait.exp 30 Aug 2014 18:57:18 -0000 1.1.1.1
++++ XXX/unit-tests/dotwait.exp 3 Oct 2017 22:43:52 -0000
+@@ -22,9 +22,9 @@ shared.2.1
+ shared.2.1
+ shared.2.99
+ shared.2.99
++cycle.1.99
++cycle.1.99
+ make: Graph cycles through `cycle.2.99'
+ make: Graph cycles through `cycle.2.98'
+ make: Graph cycles through `cycle.2.97'
+-cycle.1.99
+-cycle.1.99
+ exit status 0
+Index: unit-tests/dotwait.mk
+===================================================================
+RCS file: /volume/cvs/bmake/unit-tests/dotwait.mk,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 dotwait.mk
+--- XXX/unit-tests/dotwait.mk 30 Aug 2014 18:57:18 -0000 1.1.1.1
++++ XXX/unit-tests/dotwait.mk 3 Oct 2017 22:42:44 -0000
+@@ -11,7 +11,7 @@ PAUSE= sleep 1
+ # Ignore "--- target ---" lines printed by parallel make.
+ all:
+ .for t in ${TESTS}
+- @${.MAKE} -f ${THISMAKEFILE} -j4 $t | grep -v "^--- "
++ @${.MAKE} -f ${THISMAKEFILE} -j4 $t 2>&1 | grep -v "^--- "
+ .endfor
+
+ #
+