aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bobcat
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 01:50:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 03:31:20 -0300
commitaed1a22ff7d64c1ad7e66b31b51d5e088782aed7 (patch)
tree9cdf223197644f1d4b82d28e02d988a882f6be47 /testing/bobcat
parentfd4eec108c9677df158e0ff09e683728b5b457d0 (diff)
downloadaports-aed1a22ff7d64c1ad7e66b31b51d5e088782aed7.tar.bz2
aports-aed1a22ff7d64c1ad7e66b31b51d5e088782aed7.tar.xz
testing/bobcat: remove libressl patches
Diffstat (limited to 'testing/bobcat')
-rw-r--r--testing/bobcat/APKBUILD8
-rw-r--r--testing/bobcat/libressl-compatibility.patch33
2 files changed, 2 insertions, 39 deletions
diff --git a/testing/bobcat/APKBUILD b/testing/bobcat/APKBUILD
index fc8c9fe675..fe5a983fec 100644
--- a/testing/bobcat/APKBUILD
+++ b/testing/bobcat/APKBUILD
@@ -15,30 +15,26 @@ source="bobcat-$pkgver.tar.gz::https://github.com/fbb-git/bobcat/archive/$pkgver
dont-use-reserved-name-for-page-size.patch
avoid-gnuisms.patch
avoid-strerror_r.patch
- libressl-compatibility.patch"
+ "
builddir="$srcdir/bobcat-$pkgver/bobcat"
prepare() {
default_prepare
- cd "$builddir"
sed -i '/^#define DOC/d' INSTALL.im
echo '#define DOC "/usr/share/doc/bobcat"' >> INSTALL.im
}
build() {
- cd "$builddir"
./build light strip
./build man
}
package() {
- cd "$builddir"
./build install hlm "$pkgdir"
}
sha512sums="8752392e6feb0f3caf119ebf58423dc4cb24f0cd9f421e58ba14648baf8603235bfb44c24d5ea1ecee78a52620fe3ad2936091ec47b0de924c4af00ebc8b16f1 bobcat-4.08.01.tar.gz
6521da77c2452fb2c4b209c24e5dae04650636224efe5e75e2f2e64ab1c6457392ad4cdc4afbe79526734c8211488b2dc5915210ee7af646e7d0af04579cd484 dont-use-reserved-name-for-page-size.patch
24eb74e7dab68cb70f89459228f0f302a5214f8d45bc31e38a8d608edfa97cfe61710212fface32fc480fc4ef2fb23bbca7ed806dd40330e6da69774b3d1965d avoid-gnuisms.patch
-1129bb0666f6809ab2cca60bb164f4c557be7d27db84e41712643ee5027b8c7b62bc82e8f1c5fa9a1e737e487fe58f163afd6687d94fbacb9a23ad7818851cf0 avoid-strerror_r.patch
-02f3ca5a42d64f2831a3357b24cdc6d706f8ff26d38d87a36695f65f02730d06fb759f3d8ccb9accf93cca166954c80968ba31d16cdae3823478f7dbc917fb40 libressl-compatibility.patch"
+1129bb0666f6809ab2cca60bb164f4c557be7d27db84e41712643ee5027b8c7b62bc82e8f1c5fa9a1e737e487fe58f163afd6687d94fbacb9a23ad7818851cf0 avoid-strerror_r.patch"
diff --git a/testing/bobcat/libressl-compatibility.patch b/testing/bobcat/libressl-compatibility.patch
deleted file mode 100644
index 970bcf62d0..0000000000
--- a/testing/bobcat/libressl-compatibility.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/diffiehellman/diffiehellman.ih
-+++ b/diffiehellman/diffiehellman.ih
-@@ -15,7 +15,7 @@
- using namespace std;
- using namespace FBB;
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- inline BN_GENCB *BN_GENCB_new()
- {
---- a/digestbuf/digestbuf.ih
-+++ b/digestbuf/digestbuf.ih
-@@ -9,7 +9,7 @@
-
- #include "../ohexstreambuf/ohexstreambuf"
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- inline EVP_MD_CTX *EVP_MD_CTX_new()
- {
- EVP_MD_CTX *ret = new EVP_MD_CTX;
---- a/hmacbuf/hmacbuf.ih
-+++ b/hmacbuf/hmacbuf.ih
-@@ -7,7 +7,7 @@
- #include <bobcat/exception>
- #include "../ohexstreambuf/ohexstreambuf"
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- inline HMAC_CTX *HMAC_CTX_new()
- {