aboutsummaryrefslogtreecommitdiffstats
path: root/testing/borgmatic
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-11 00:04:01 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 20:29:17 -0300
commitd6abbefc9ecaef093724879e2cb6dbb83f9c2dbc (patch)
tree40009e37b1f4e2050402536413a771009a4dfdeb /testing/borgmatic
parentf35e4c31a29279baaddc2ca30266e3b2c5013f34 (diff)
downloadaports-d6abbefc9ecaef093724879e2cb6dbb83f9c2dbc.tar.bz2
aports-d6abbefc9ecaef093724879e2cb6dbb83f9c2dbc.tar.xz
testing/borgmatic: new aport
Diffstat (limited to 'testing/borgmatic')
-rw-r--r--testing/borgmatic/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/borgmatic/APKBUILD b/testing/borgmatic/APKBUILD
new file mode 100644
index 0000000000..de3153d6f7
--- /dev/null
+++ b/testing/borgmatic/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=borgmatic
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Simple, configuration-driven backup software for servers and workstations"
+url="https://torsion.org/borgmatic/"
+arch="noarch !s390x" # limited by borgbackup
+license="GPL-3.0-or-later"
+depends="borgbackup python3 py3-pykwalify py3-requests py3-ruamel.yaml py3-colorama"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov py3-flexmock"
+source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/witten/borgmatic/archive/$pkgver.tar.gz"
+builddir="$srcdir/borgmatic"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # omit a simple test that requires borgmatic to be available in $PATH
+ pytest -k "not test_borgmatic_version_matches_news_version"
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+}
+
+sha512sums="446c74deb8fa57ede9a7e4ae1331119d34934cba6aec436f67582b752bb48f7203bc65c50cbe0ff426984785aeb444c6ff8e3dadcf1285ebe90b613b71d5e35e borgmatic-1.5.1.tar.gz"