aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bovo
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-04 11:45:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-04 08:35:49 -0300
commit9f8e38c5733465411afcd7dfd626fc66c3a2b271 (patch)
treecfd050abfd4c38bfe156965c415aa3369a05ea0b /testing/bovo
parent45eb151556bbe5615357cf651aa288fe3b17fca9 (diff)
downloadaports-9f8e38c5733465411afcd7dfd626fc66c3a2b271.tar.bz2
aports-9f8e38c5733465411afcd7dfd626fc66c3a2b271.tar.xz
testing/bovo: new aport
Diffstat (limited to 'testing/bovo')
-rw-r--r--testing/bovo/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/bovo/APKBUILD b/testing/bovo/APKBUILD
new file mode 100644
index 0000000000..3d6c937fdd
--- /dev/null
+++ b/testing/bovo/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=bovo
+pkgver=19.08.0
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/games/org.kde.bovo"
+pkgdesc="A Gomoku like game for two players"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev kxmlgui-dev libkdegames-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="d0829acc26414224351da2dc21d2960bbb1e881b14fbb7715ada7a397586a79165c9c4cfc8dea4fbafbbbd7f0240d462e5213f262da8466c4ea11897d9e0a500 bovo-19.08.0.tar.xz"