aboutsummaryrefslogtreecommitdiffstats
path: root/testing/breeze-icons
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-22 00:35:33 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 17:14:47 +0000
commit54d5d94651476467c3548d2db5681ffd97a18587 (patch)
treebeebae92838c7517c3933bf4de1c8ff6ee56dbd3 /testing/breeze-icons
parent994a18c6ab27aa2633910ae813031e73a59537d7 (diff)
downloadaports-54d5d94651476467c3548d2db5681ffd97a18587.tar.bz2
aports-54d5d94651476467c3548d2db5681ffd97a18587.tar.xz
testing/breeze-icons: new aport
Closes GH-7992
Diffstat (limited to 'testing/breeze-icons')
-rw-r--r--testing/breeze-icons/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/breeze-icons/APKBUILD b/testing/breeze-icons/APKBUILD
new file mode 100644
index 0000000000..334a7629b1
--- /dev/null
+++ b/testing/breeze-icons/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=breeze-icons
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Breeze icon themes"
+arch="noarch"
+url="https://community.kde.org/Frameworks"
+license="LGPL-3.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBINARY_ICONS_RESOURCE=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E dupe
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="3733fe1634dbfce4f5713689c334948f28f133936c7b069088b68b1c468fc0bdf6a95a6743c10ed3a0d13afd6814756e9ff32f1da34a33bebd579044507a92d5 breeze-icons-5.58.0.tar.xz"