aboutsummaryrefslogtreecommitdiffstats
path: root/testing/brotli/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-13 05:51:24 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-18 14:35:11 +0000
commit7f7b310f5311e0e7604bafe57c4a3e5ff1941235 (patch)
tree27109203ce2a0b00bee752578585dc131c2b3742 /testing/brotli/APKBUILD
parentc21c51817e1215615b7e36431f6650dfb18faf4f (diff)
downloadaports-7f7b310f5311e0e7604bafe57c4a3e5ff1941235.tar.bz2
aports-7f7b310f5311e0e7604bafe57c4a3e5ff1941235.tar.xz
testing/brotli: optimize on mips*, s390x
1) Recognize s390x and mips64* as 64-bit architectures to enable 64-bit code path. 2) Enable direct unaligned loads/stores for s390x. See "Integral Boundaries" in SA22-7832-xx. 3) Enable unaligned access using LWL/LWR/etc instructions on pre-R6 mips*. This doubles "brotli -1" compression speed on P5600 (~30% for "brotli --best") and makes the brotli executable smaller by ~10%. 4) Use gcc/clang __builtin_bswapXX on big-endian architectures. On s390x this reduces byte-swapped unaligned loads/stores to single LRVx/STRVx instruction. On current big-endian mips* (pre-R2) this changes nothing however allows for shorter byte swap sequences on R2+. Test suite still passes on x86_64, mipseln8hf (hardware) and under qemu-s390x.
Diffstat (limited to 'testing/brotli/APKBUILD')
-rw-r--r--testing/brotli/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/testing/brotli/APKBUILD b/testing/brotli/APKBUILD
index 06a6764d3a..d34babdd4c 100644
--- a/testing/brotli/APKBUILD
+++ b/testing/brotli/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=brotli
pkgver=1.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="Generic lossless compressor"
url="https://github.com/google/brotli"
arch="all"
license="MIT"
makedepends="cmake"
subpackages="$pkgname-doc $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/google/brotli/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/brotli/archive/v$pkgver.tar.gz
+ optimize-mips-s390x.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -46,4 +48,5 @@ package() {
done
}
-sha512sums="a82362aa36d2f2094bca0b2808d9de0d57291fb3a4c29d7c0ca0a37e73087ec5ac4df299c8c363e61106fccf2fe7f58b5cf76eb97729e2696058ef43b1d3930a brotli-1.0.7.tar.gz"
+sha512sums="a82362aa36d2f2094bca0b2808d9de0d57291fb3a4c29d7c0ca0a37e73087ec5ac4df299c8c363e61106fccf2fe7f58b5cf76eb97729e2696058ef43b1d3930a brotli-1.0.7.tar.gz
+59e934578ce23b703f8f25f56578f8e9fd1466a9844b6f67b542acd6496df352548e3762697dc3851cfd0f8e1bad170bfdaa3e8a87c901fe81e2f3042e3aee84 optimize-mips-s390x.patch"