aboutsummaryrefslogtreecommitdiffstats
path: root/testing/buildbot
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 12:27:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 12:27:34 +0000
commit87c300e4a4b56d47f71e2f4b18e8e58112e20d41 (patch)
tree912fd1cc440e08754b3a41faf22bade06a24ab0e /testing/buildbot
parent537cba6faae5e71f27ace230e2fda7d447b69112 (diff)
downloadaports-87c300e4a4b56d47f71e2f4b18e8e58112e20d41.tar.bz2
aports-87c300e4a4b56d47f71e2f4b18e8e58112e20d41.tar.xz
community/buildbot: upgrade to 0.9.0rc2, moved from testing
Diffstat (limited to 'testing/buildbot')
-rw-r--r--testing/buildbot/APKBUILD61
-rw-r--r--testing/buildbot/buildbot.pre-install6
-rw-r--r--testing/buildbot/buildmaster.confd10
-rw-r--r--testing/buildbot/buildmaster.initd69
4 files changed, 0 insertions, 146 deletions
diff --git a/testing/buildbot/APKBUILD b/testing/buildbot/APKBUILD
deleted file mode 100644
index c85b4dee57..0000000000
--- a/testing/buildbot/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=buildbot
-pkgver=0.8.9
-pkgrel=2
-pkgdesc="Continuous integration testing framework"
-url="http://buildbot.net/"
-arch="noarch"
-license="GPLv2"
-depends="python py-twisted
- py-simplejson py-sqlalchemy7 py-pysqlite py-jinja2 py-sqlalchemy-migrate
- py-dateutil py-setuptools"
-depends_dev=""
-makedepends="python-dev"
-install="${pkgname}.pre-install"
-BUILDBOT_USER=buildbot
-BUILDBOT_GROUP=buildbot
-pkgusers="$BUILDBOT_USER"
-pkggroups="$BUILDBOT_GROUP"
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
- buildmaster.initd
- buildmaster.confd"
-
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- default_prepare || return 1
-}
-
-build() {
- cd "$builddir"
- python setup.py build || return 1
-}
-
-package() {
- cd "$builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" \
- || return 1
- install -D -m 755 \
- "$srcdir"/buildmaster.initd \
- "$pkgdir"/etc/init.d/buildmaster \
- || return 1
- install -D -m 644 \
- "$srcdir"/buildmaster.confd \
- "$pkgdir"/etc/conf.d/buildmaster \
- || return 1
- install -d -o $BUILDBOT_USER -g $BUILDBOT_GROUP \
- "$pkgdir"/var/lib/buildmaster \
- || return 1
-}
-
-md5sums="b4c723d1e0324ea19511e622e420c6e7 buildbot-0.8.9.tar.gz
-b8a4cd31065d2fcd305e76c9e4bd2103 buildmaster.initd
-b3cd43ecb53b66433e0384ad922ffde1 buildmaster.confd"
-sha256sums="6b9e465e6d4825fe1f09d28505318fdb1a75b283c80a140af0f2e2a5039cfa8a buildbot-0.8.9.tar.gz
-ddc5b7c504702da9e7452d04070a65afb8f0ff9082b3f62e8dfcebc8c2e5256e buildmaster.initd
-bb7f93e3867b32a25e2445a66d40573fa5073a80e73e35ae2a904db715f870c6 buildmaster.confd"
-sha512sums="5788b268689d8594592c2c5dc8c2d0178aca64c1816c7faa0181b446f8b657a4781dbb9a9d4ea0965ccfcd217dc485973fda01bf9d7cac638328dfef01959484 buildbot-0.8.9.tar.gz
-2e65d22f1b94433ba11839fb3434d072f9ff8132396b03fdcdb3b437778679d1699534296fbb851d2661a3a7a0bce4ef1f94c49e7910419557e4055f2ed1a4d5 buildmaster.initd
-d9339c30d3a92e92b41b0e3139ec89ecbd1460b0e4ee6c6fe2560c4307b2eb3f29b838c2f2312b9c7049bd95eaf652d09039227c691af805bc25a36999ec1840 buildmaster.confd"
diff --git a/testing/buildbot/buildbot.pre-install b/testing/buildbot/buildbot.pre-install
deleted file mode 100644
index 7a1deeded1..0000000000
--- a/testing/buildbot/buildbot.pre-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-addgroup -S buildbot 2>/dev/null
-adduser -S -D -H -h /home/buildbot -s /sbin/nologin -G buildbot -g buildbot buildbot 2>/dev/null
-
-exit 0
diff --git a/testing/buildbot/buildmaster.confd b/testing/buildbot/buildmaster.confd
deleted file mode 100644
index e489d66f9d..0000000000
--- a/testing/buildbot/buildmaster.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-
-# Path to the build master's basedir.
-BASEDIR=/var/lib/buildmaster
-
-# User account for the buildmaster.
-# The basedir should be owned by this user.
-USERNAME=buildbot
-
-# Extra options to pass to twistd.
-TWISTD_OPTS=""
diff --git a/testing/buildbot/buildmaster.initd b/testing/buildbot/buildmaster.initd
deleted file mode 100644
index 05c1a10104..0000000000
--- a/testing/buildbot/buildmaster.initd
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_started_commands="reload"
-extra_stopped_commands="create"
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ -z "${BASEDIR}" ]; then
- eerror "BASEDIR not set"
- return 1
- fi
- if [ -z "${USERNAME}" ]; then
- eerror "USERNAME not set"
- return 1
- fi
- if [ ! -d "${BASEDIR}" ]; then
- eerror "${BASEDIR} is not a directory"
- return 1
- fi
- if [ ! -e "${BASEDIR}/buildbot.tac" ]; then
- eerror "${BASEDIR} does not contain buildbot.tac"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting buildmaster in ${BASEDIR}"
- start-stop-daemon --start -u "${USERNAME}" \
- --pidfile "${BASEDIR}/buildmaster.pid" \
- --exec /usr/bin/python -- /usr/bin/twistd \
- --no_save \
- --logfile="${BASEDIR}/twistd.log" \
- --pidfile="${BASEDIR}/buildmaster.pid" \
- --python="${BASEDIR}/buildbot.tac"
- eend $?
-}
-
-stop() {
- ebegin "Stopping buildmaster in ${BASEDIR}"
- start-stop-daemon --stop --pidfile "${BASEDIR}/buildmaster.pid"
- eend $?
-}
-
-reload() {
- ebegin "Reconfiguring buildmaster in ${BASEDIR}"
- start-stop-daemon --signal HUP --pidfile \
- "${BASEDIR}"/buildmaster.pid
- eend $?
-}
-
-create() {
- if [ -e "${BASEDIR}"/buildbot.tac -o -e "${BASEDIR}"/master.cfg ]; then
- eerror "${BASEDIR} already contains buildbot.tac or master.cfg"
- return 1
- fi
- ebegin "Creating buildmaster in ${BASEDIR}"
- start-stop-daemon -u "${USERNAME}" \
- --exec /usr/bin/buildbot \
- -- create-master -r "${BASEDIR}"
- mv "${BASEDIR}"/master.cfg.sample "${BASEDIR}"/master.cfg
- ewarn "Remember to customize exemplary master.cfg in ${BASEDIR}"
- eend $?
-}