aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cabal
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-10 11:54:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-10 11:54:36 +0000
commit0ed39b5c6bab0413c0551e3202389887dbd09d81 (patch)
tree98a692302cc8cb9a0c38314f313bfda624140cc1 /testing/cabal
parent522d43089adf45cf9502991082f136208fc2cef8 (diff)
downloadaports-0ed39b5c6bab0413c0551e3202389887dbd09d81.tar.bz2
aports-0ed39b5c6bab0413c0551e3202389887dbd09d81.tar.xz
Revert "testing/cabal: new aport"
Diffstat (limited to 'testing/cabal')
-rw-r--r--testing/cabal/APKBUILD44
-rw-r--r--testing/cabal/cabal-0001-force-ld.gold.patch10
2 files changed, 0 insertions, 54 deletions
diff --git a/testing/cabal/APKBUILD b/testing/cabal/APKBUILD
deleted file mode 100644
index 19858d88f9..0000000000
--- a/testing/cabal/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-#-*-mode: Shell-script; coding: utf-8;-*-
-# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
-pkgname=cabal
-pkgver=1.24.0.2
-pkgrel=0
-pkgdesc="The Haskell Cabal"
-url="http://haskell.org"
-arch="x86_64 armhf"
-license="bsd3"
-depends="musl zlib gmp"
-makedepends="ghc gmp-dev libffi-dev zlib-dev binutils-gold chrpath"
-install=""
-subpackages="$pkgname-doc"
-source="
- https://www.haskell.org/$pkgname/release/$pkgname-install-$pkgver/$pkgname-install-$pkgver.tar.gz
- cabal-0001-force-ld.gold.patch
-"
-builddir="$srcdir/$pkgname-install-$pkgver"
-
-build() {
- cd "$builddir"
- (
- export HOME="$builddir"
- export NO_DOCUMENTATION=1
- export EXTRA_BUILD_OPTS="--ghc-option=-fllvm"
- ./bootstrap.sh || return 1
- ) || return 1
-}
-
-doc() {
- default_doc
- install -Dm644 "$builddir/LICENSE" "$subpkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
-}
-
-package() {
- install -Dm755 "$builddir/dist/build/cabal/cabal" "$pkgdir/usr/bin/cabal" || return 1
- chrpath -d "$pkgdir/usr/bin/cabal" || return 1
-}
-md5sums="2577c3d7712a74614bf7cc63a5341cab cabal-install-1.24.0.2.tar.gz
-dbdcab13dfd1c0afac66ad5213885fc0 cabal-0001-force-ld.gold.patch"
-sha256sums="2ac8819238a0e57fff9c3c857e97b8705b1b5fef2e46cd2829e85d96e2a00fe0 cabal-install-1.24.0.2.tar.gz
-9b376e1743e4a8cc6b422bd6cef6c08a4e74d83ec2712a4d5a66c2aaccb482d6 cabal-0001-force-ld.gold.patch"
-sha512sums="bd055a52ff0ac697e6f21a588d53dd811d50ee9410659a242c00a5665b360ef10c024df4872b9070c33aa49f779c8817b883b40087d3f4e0be4096a54b2ad5f0 cabal-install-1.24.0.2.tar.gz
-cb83ea703c3d0d5124a9f35606250c5bc71b67c141512bcdaa285b8a9bb99c5ca34ad1c3cf0c73ea0486215bb46285989ada4967f7e7a972e58cefdbc4eab8a9 cabal-0001-force-ld.gold.patch"
diff --git a/testing/cabal/cabal-0001-force-ld.gold.patch b/testing/cabal/cabal-0001-force-ld.gold.patch
deleted file mode 100644
index 76a6a1528c..0000000000
--- a/testing/cabal/cabal-0001-force-ld.gold.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/bootstrap.sh.original 2016-02-10 06:45:52.000000000 -0600
-+++ a/bootstrap.sh 2016-03-18 23:28:06.000000000 -0500
-@@ -74,6 +74,7 @@
-
- # Fall back to "ld"... might work.
- [ -$LINK- = -""- ] && LINK=ld
-+LINK="ld.gold"
-
- # And finally, see if we can compile and link something.
- echo 'int main(){}' | $CC -xc - -o /dev/null ||