aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cachefilesd-inotify/APKBUILD
diff options
context:
space:
mode:
authorJake Buchholz <tomalok@gmail.com>2019-10-07 00:08:48 +0000
committerRasmus Thomsen <oss@cogitri.dev>2019-10-26 23:09:05 +0200
commit00be3a44472d6239a5052218d41d055fba9b3634 (patch)
tree1798ab8bedfbb540ef7747fe02abbb4a46f5c22d /testing/cachefilesd-inotify/APKBUILD
parentb64206c6e9c5f450ad714a55f83464d969379dd3 (diff)
downloadaports-00be3a44472d6239a5052218d41d055fba9b3634.tar.bz2
aports-00be3a44472d6239a5052218d41d055fba9b3634.tar.xz
testing/cachefilesd-inotify: new aport
This is a fork of community/cachefilesd that has been patched to work with INOTIFY instead of DNOTIFY (which is disabled in most Alpine Linux kernels). It is hoped that this fork will eventually be brought back into cachefilesd's mainline codebase, but in the meantime, this package should unblock those who might have wanted to use cachefilesd with Alpine Linux.
Diffstat (limited to 'testing/cachefilesd-inotify/APKBUILD')
-rw-r--r--testing/cachefilesd-inotify/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/cachefilesd-inotify/APKBUILD b/testing/cachefilesd-inotify/APKBUILD
new file mode 100644
index 0000000000..71a7467fb9
--- /dev/null
+++ b/testing/cachefilesd-inotify/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Jake Buchholz <tomalok@gmail.com>
+# Maintainer: Jake Buchholz <tomalok@gmail.com>
+pkgname=cachefilesd-inotify
+pkgver=0.11.0
+pkgrel=0
+pkgdesc="Userspace daemon acting as a backend for FS-Cache (uses INOTIFY instead of DNOTIFY)"
+url="https://gitlab.com/tomalok/cachefilesd-inotify"
+arch="all"
+license="GPL-2.0-or-later"
+depends="attr"
+makedepends="rpm file"
+provides="cachefilesd=$pkgver-r$pkgrel"
+replaces="cachefilesd"
+options="!check"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="https://gitlab.com/tomalok/cachefilesd-inotify/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2
+ cachefilesd.initd"
+
+build() {
+ sed -i "s#/sbin/#/usr/bin/#g" cachefilesd.c
+ sed -i "s#/sbin/#/usr/bin/#g" cachefilesd.service
+ sed -i "s/^secctx/#secctx/g" cachefilesd.conf
+ make CFLAGS="$CFLAGS"
+}
+
+package() {
+ make DESTDIR="$pkgdir" SBINDIR=/usr/bin install
+ mkdir -p "$pkgdir"/var/cache/fscache
+ install -D -m 755 "$srcdir/cachefilesd.initd" "$pkgdir/etc/init.d/cachefilesd"
+}
+
+sha512sums="f283d0d2357da648515225a5162b53a4603fc466d291a68c4833a39ce1aed2784f9734a23ebcb47d1efbea0d3659733f9c1d8a0137e6e98281e6f4085328d049 cachefilesd-inotify-0.11.0.tar.bz2
+854b66470ace24caf24e979de3c1c12a426972bc745823b3a0f47ac80811ac5da4fa6a249e65386acdec2e7561178bb1d2c4b301a2178458f10496bb8eac5b2f cachefilesd.initd"