aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cadaver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-22 08:57:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-22 08:57:32 +0000
commit51182271f71c4e038d07fee3fcda25d996b705cf (patch)
treeeb7e367e7fd65cd363fe059e995fc379557ba824 /testing/cadaver
parent0f18708d11ed94c07c208ec5e013c818d2345c2c (diff)
downloadaports-51182271f71c4e038d07fee3fcda25d996b705cf.tar.bz2
aports-51182271f71c4e038d07fee3fcda25d996b705cf.tar.xz
testing/cadaver: claim maintainership, minor cleanup
Diffstat (limited to 'testing/cadaver')
-rw-r--r--testing/cadaver/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/cadaver/APKBUILD b/testing/cadaver/APKBUILD
index 16e493b14c..a3bcccdbf4 100644
--- a/testing/cadaver/APKBUILD
+++ b/testing/cadaver/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: ScrumpyJack <scrumpyjack@me.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cadaver
pkgver=0.23.3
-pkgrel=0
+pkgrel=1
pkgdesc="Cadaver is a command line webDAV client for Linux"
url="http://webdav.org/cadaver/"
arch="all"
@@ -18,6 +18,7 @@ _builddir=${srcdir}/${pkgname}-${pkgver}
prepare() {
local i
cd "$_builddir"
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -28,9 +29,11 @@ prepare() {
build() {
cd "$_builddir"
./configure \
- --prefix=/usr \
- --with-ssl=openssl \
- || return 1
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-ssl=openssl \
+ || return 1
make
}