aboutsummaryrefslogtreecommitdiffstats
path: root/testing/camlp4
diff options
context:
space:
mode:
authorJon Ong <jonongjs@rottenmage.com>2016-07-07 23:57:26 +0800
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-08 09:53:42 +0200
commit40a32b8c3a58f53a282c6e16234c75b3983fcae5 (patch)
tree0e7b84978b0923cde7cc60fa12497567a124c87a /testing/camlp4
parentd73dca5d546233fd38bd8c3c3d3682f111c53626 (diff)
downloadaports-40a32b8c3a58f53a282c6e16234c75b3983fcae5.tar.bz2
aports-40a32b8c3a58f53a282c6e16234c75b3983fcae5.tar.xz
testing/camlp4: new aport
https://github.com/ocaml/camlp4/releases Caml preprocessor and pretty-printer
Diffstat (limited to 'testing/camlp4')
-rw-r--r--testing/camlp4/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/camlp4/APKBUILD b/testing/camlp4/APKBUILD
new file mode 100644
index 0000000000..8aa6cb53f0
--- /dev/null
+++ b/testing/camlp4/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer:
+pkgname=camlp4
+pkgver=4.03
+_versuffix='+1'
+pkgrel=0
+pkgdesc="Caml preprocessor and pretty-printer"
+url="https://github.com/ocaml/camlp4/releases"
+arch="all"
+license="GPL2"
+depends="ocaml"
+makedepends="ocamlbuild"
+options="!makeflags !emptydirs staticlibs"
+install=""
+subpackages=""
+source="${pkgver}-${pkgver}${_versuffix}.tar.gz::https://github.com/ocaml/camlp4/archive/${pkgver}${_versuffix}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver${_versuffix/+/-}"
+build() {
+ cd "$builddir"
+
+ ./configure || return 1
+ make -j1 all camlp4/META || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make BINDIR="$pkgdir/usr/bin" \
+ LIBDIR="$pkgdir/usr/lib/ocaml" \
+ PKGDIR="$pkgdir/usr/lib/ocaml" \
+ install install-META || return 1
+}
+md5sums="65ece8d2c8f4b1e06d62323e78759a7c 4.03-4.03+1.tar.gz"
+sha256sums="6eefeacced81cca59ddf90c2538505fd5cd6596a3fc1acf4971e9796c2e7f2ae 4.03-4.03+1.tar.gz"
+sha512sums="0a329e18deffebb5245415f822f91e692076fca4dbe38748f18e72f417ce7354faed744fdff25f9976659192cb02d56ceb2cf1be5c64da463413ec4a28a9d3ac 4.03-4.03+1.tar.gz"