aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cargo/APKBUILD
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-16 18:08:00 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-04-21 01:46:11 +0200
commit3bce8f6bae91e07093fd7311601abc61fcce599a (patch)
tree81606dee84ececa5da40a1b6f1ed4dde92d04b92 /testing/cargo/APKBUILD
parent99199c93f79b25a673009a43b281b0c6ffbfd0a1 (diff)
downloadaports-3bce8f6bae91e07093fd7311601abc61fcce599a.tar.bz2
aports-3bce8f6bae91e07093fd7311601abc61fcce599a.tar.xz
testing/cargo: work properly with new Rust triple
Diffstat (limited to 'testing/cargo/APKBUILD')
-rw-r--r--testing/cargo/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/cargo/APKBUILD b/testing/cargo/APKBUILD
index 8d75affd83..9efda9b3cf 100644
--- a/testing/cargo/APKBUILD
+++ b/testing/cargo/APKBUILD
@@ -18,14 +18,14 @@ subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch"
# NOTE: Cargo is self-hosted, so you need cargo to build cargo (ugh).
# TODO: Implement some support for verifying crates fetched by cargo!
-_ctarget="$CARCH-unknown-linux-musl"
+_cbuild="$CARCH-unknown-linux-musl"
source="$pkgname-$pkgver.tar.gz::https://github.com/rust-lang/$pkgname/archive/$pkgver.tar.gz
https://github.com/rust-lang/rust-installer/archive/$_installer_gitrev/rust-installer-$_installer_gitrev.tar.gz
- cargo-$_bootstrap_gitrev-$_ctarget.tar.gz::https://s3.amazonaws.com/rust-lang-ci/cargo-builds/$_bootstrap_gitrev/cargo-nightly-$_ctarget.tar.gz
+ cargo-$_bootstrap_gitrev-$_cbuild.tar.gz::https://s3.amazonaws.com/rust-lang-ci/cargo-builds/$_bootstrap_gitrev/cargo-nightly-$_cbuild.tar.gz
fix-test-build-auth.patch"
builddir="$srcdir/$pkgname-$pkgver"
-_bootstrap_cargo="$srcdir/cargo-nightly-$_ctarget/cargo/bin/cargo"
+_bootstrap_cargo="$srcdir/cargo-nightly-$_cbuild/cargo/bin/cargo"
export CARGOFLAGS="--locked"
export CARGO_HOME="$srcdir/.cargo"
@@ -54,13 +54,13 @@ build() {
check() {
cd "$builddir"
- ./target/$_ctarget/release/cargo --version
+ ./target/$CTARGET/release/cargo --version
# XXX: ignore test failures for now
CFG_DISABLE_CROSS_TESTS=1 \
"$_bootstrap_cargo" test \
--release \
- --target "$_ctarget" \
+ --target "$CTARGET" \
--no-fail-fast \
--verbose || true
}