aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cdist
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2018-12-12 21:15:43 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 09:17:36 +0000
commit1e2838bc2e9c2f44619ad51b4a0b4ea76471394c (patch)
tree8a1ee0f5cc0bed13d0bbb56619ecfba0b0067f70 /testing/cdist
parent08bc0fa65ea90cb7ec029778e205ce097279baa2 (diff)
downloadaports-1e2838bc2e9c2f44619ad51b4a0b4ea76471394c.tar.bz2
aports-1e2838bc2e9c2f44619ad51b4a0b4ea76471394c.tar.xz
testing/cdist: new aport
A Usable Configuration Management System https://nico.schottelius.org/software/cdist/
Diffstat (limited to 'testing/cdist')
-rw-r--r--testing/cdist/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/cdist/APKBUILD b/testing/cdist/APKBUILD
new file mode 100644
index 0000000000..65c0a8d0f7
--- /dev/null
+++ b/testing/cdist/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=cdist
+pkgver=4.10.4
+pkgrel=0
+pkgdesc="A Usable Configuration Management System"
+arch="noarch"
+url="https://www.nico.schottelius.org/software/cdist/"
+options="!check"
+license="GPL-3.0"
+depends="python3"
+source="https://github.com/ungleich/${pkgname}/releases/download/4.10.4/${pkgname}-${pkgver}.tar.gz"
+
+package() {
+ ./bin/${pkgname} 2> /dev/null
+ python3 setup.py build install --root="${pkgdir}"
+ find "$pkgdir" -type d -exec chmod 0755 {} \;
+ find "$pkgdir" -type f -exec chmod a+r {} \;
+}
+sha512sums="19b6bd824352d77f331a2bb1bec83066fb328550249068c8037e47e9e51aba743d96119cffd5fcdefb99d1f69444fb7c608a563dfcbccfc3f2e2700fee103636 cdist-4.10.4.tar.gz"