aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cdogs-sdl
diff options
context:
space:
mode:
authorVictor Diego Alegandro Diaz Urbaneja <sodomon2@gmail.com>2020-01-06 03:33:40 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-01-25 22:01:47 +0100
commit6ecc81892ce921c9f6ee3595d39d020d5fe86eff (patch)
tree1903ff7137822e525afd87373f0f1a61b11e86b0 /testing/cdogs-sdl
parentfd19e19c220613202d4a4613fca0f0a31bcc9595 (diff)
downloadaports-6ecc81892ce921c9f6ee3595d39d020d5fe86eff.tar.bz2
aports-6ecc81892ce921c9f6ee3595d39d020d5fe86eff.tar.xz
testing/cdogs-sdl:new aport
Classic overhead run-and-gun game https://cxong.github.io/cdogs-sdl/
Diffstat (limited to 'testing/cdogs-sdl')
-rw-r--r--testing/cdogs-sdl/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/cdogs-sdl/APKBUILD b/testing/cdogs-sdl/APKBUILD
new file mode 100644
index 0000000000..c005f7577b
--- /dev/null
+++ b/testing/cdogs-sdl/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
+# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
+pkgname=cdogs-sdl
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Classic overhead run-and-gun game"
+url="https://cxong.github.io/cdogs-sdl/"
+arch="x86_64 x86"
+license="GPL"
+depends="sdl2 sdl2_mixer sdl2_image mesa"
+makedepends="cmake"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cxong/$pkgname/archive/$pkgver.tar.gz"
+
+build() {
+ cmake CMakeLists.txt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCDOGS_DATA_DIR=/usr/share/cdogs-sdl/ \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="33ff3a0fa9c8f5d32b79caf52fc9cf1472d71245821f841fdaa926acaa7c4342884be975962f128e5d5f24e2ad86923547116f8ca29d157960cc1181d4aa6cba cdogs-sdl-0.7.0.tar.gz"