aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cdw
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
commite7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc (patch)
treec6b816e7ba8f9b659e1be415ebf1dac4262c3b82 /testing/cdw
parent452d447d89b3a3775b7f602d7352a8cfe8a0f9d4 (diff)
downloadaports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.bz2
aports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.xz
testing/*: move to main
Diffstat (limited to 'testing/cdw')
-rw-r--r--testing/cdw/APKBUILD54
-rw-r--r--testing/cdw/cdw_colors.c.patch10
-rw-r--r--testing/cdw/cdw_fs.c.patch11
-rw-r--r--testing/cdw/main.c.patch14
4 files changed, 0 insertions, 89 deletions
diff --git a/testing/cdw/APKBUILD b/testing/cdw/APKBUILD
deleted file mode 100644
index 6996d68654..0000000000
--- a/testing/cdw/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Contributor: ScrumpyJack <scrumpyjack@me.com>
-# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=cdw
-pkgver=0.8.0
-pkgrel=1
-pkgdesc="cdw is a front-end for cd recoding tools"
-url="http://cdw.sf.net"
-arch="all"
-license="GPL2"
-depends="cdrkit"
-depends_dev="ncurses-dev libcdio-dev libburn-dev bison gettext-dev"
-makedepends="$depends_dev linux-headers"
-install=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz
- main.c.patch
- cdw_fs.c.patch
- cdw_colors.c.patch"
-
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- export LIBS="-lintl" && ./configure --prefix=/usr
- make
-}
-
-package() {
- cd "$_builddir"
- chmod +x ${srcdir}/${pkgname}-${pkgver}/install-sh
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="60a8d094343b50b436a013737261e92c cdw-0.8.0.tar.gz
-1a35f4cfe4ebf18bb9df4553c0da877c main.c.patch
-36c9275ca278920db0a42029a94307cc cdw_fs.c.patch
-919951dbb5ffa814b56b2f98529cc180 cdw_colors.c.patch"
-sha256sums="8f5bd7ed41bc07a84c5aa693bed3c38420e60ba6a3b5ae6ff8e41d78a4665fd2 cdw-0.8.0.tar.gz
-f20a3a158c9feb9503b412a7ebf924c158f688a2f117bffbe1af41555e2dea80 main.c.patch
-f233fa0622d7f348a5d96529657525bc4b943f520d317812f4bf0635ee9d40a2 cdw_fs.c.patch
-34baba8bac6649cce0f5d69978366df8a7dd92ff6cb61941468eae9e6de539c4 cdw_colors.c.patch"
-sha512sums="67fd9e397800187baafff425fd77ae9ba679a7b396736004f305accea3c3c9ca215d70dac0410fd8ef9ed016f7ce11c3859c84bfa04e3234cee84201605175d0 cdw-0.8.0.tar.gz
-1c3bd9ec2faad0833ba0042a5a760f0b691f6db9cac3badf7059ed85d791d5b843f03c5c798c33e3a15c0398feee95cd861d01b4a883954af4b558871978c670 main.c.patch
-292a822db0e3c5aec8f61af4463a868183d8a9faf05b2e2f023ad95bd918bc8a5b24eb6b990d0313a60f6f5494f9aba4fc36e53348d1f7ec0838eaeaf72a70ae cdw_fs.c.patch
-60f882f246ca3739e207d91c95ddf41b03f306012fa771ecf5f9a62497756b8e4d615c2bbc71bfa02cab3cd77b6f6ecf7367a9ef92319f46764f89412b1e2cff cdw_colors.c.patch"
diff --git a/testing/cdw/cdw_colors.c.patch b/testing/cdw/cdw_colors.c.patch
deleted file mode 100644
index 87bff5b052..0000000000
--- a/testing/cdw/cdw_colors.c.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- cdw-0.8.0/src/user_interface/cdw_colors.c
-+++ cdw-0.8.0/src/user_interface/cdw_colors.c.changed
-@@ -22,6 +22,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <stdlib.h>
-+#include <limits.h>
- // #include <dirent.h> /* PATH_MAX */
-
- #include "cdw_ncurses.h"
diff --git a/testing/cdw/cdw_fs.c.patch b/testing/cdw/cdw_fs.c.patch
deleted file mode 100644
index a7ddfd9394..0000000000
--- a/testing/cdw/cdw_fs.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cdw-0.8.0/src/native_file_system/cdw_fs.c
-+++ cdw-0.8.0/src/native_file_system/cdw_fs.c.changed
-@@ -24,6 +24,8 @@
- #include <string.h>
- #include <errno.h>
- #include <stdlib.h>
-+#include <limits.h>
-+#include <paths.h>
-
- #include "cdw_fs.h"
- #include "cdw_file_picker.h"
diff --git a/testing/cdw/main.c.patch b/testing/cdw/main.c.patch
deleted file mode 100644
index b9ff47346c..0000000000
--- a/testing/cdw/main.c.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- cdw-0.8.0/src/main.c
-+++ cdw-0.8.0/src/main.c.changed
-@@ -44,9 +44,9 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <mcheck.h>
-+/* #include <mcheck.h> */
- #include <signal.h> /* sig_atomic_t */
--
-+#include <limits.h>
- #include <dirent.h> /* PATH_MAX */
-
- #include "main.h"