aboutsummaryrefslogtreecommitdiffstats
path: root/testing/checkbashisms
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-15 14:34:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-15 14:34:18 +0000
commit4faed39d846e816db74acb6f57776e3b95ca041b (patch)
tree6d4f7a713918ad8d86788ef192ef0bc9556ec66e /testing/checkbashisms
parent79a5c3118e395916ec60e32d56841118dd120997 (diff)
downloadaports-4faed39d846e816db74acb6f57776e3b95ca041b.tar.bz2
aports-4faed39d846e816db74acb6f57776e3b95ca041b.tar.xz
testing/checkbashisms: new aport
Basic checks on shell scripts for the presence of non portable syntax http://sourceforge.net/projects/checkbaskisms/
Diffstat (limited to 'testing/checkbashisms')
-rw-r--r--testing/checkbashisms/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/checkbashisms/APKBUILD b/testing/checkbashisms/APKBUILD
new file mode 100644
index 0000000000..05ec5b6b8a
--- /dev/null
+++ b/testing/checkbashisms/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa
+pkgname=checkbashisms
+pkgver=2.0.0.2
+pkgrel=0
+pkgdesc="Basic checks on shell scripts for the presence of non portable syntax"
+url="http://sourceforge.net/projects/checkbaskisms/"
+arch="noarch"
+license="GPL"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="1261d0c5aafedc15ab4405c1969deacf checkbashisms"