aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cherrytree
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2019-02-05 19:47:24 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-12 07:33:29 +0000
commitb0daa6637d75704d1bad97c677745d7e9136809e (patch)
tree7eec5a69404c44f759069f802e2ba613d2c5a8e3 /testing/cherrytree
parente90a0222e06e3c32b0172ea6970097c9a83cf591 (diff)
downloadaports-b0daa6637d75704d1bad97c677745d7e9136809e.tar.bz2
aports-b0daa6637d75704d1bad97c677745d7e9136809e.tar.xz
testing/cherrytree: new aport
https://www.giuspen.com/cherrytree/ Hierarchical note-taking app featuring rich text.
Diffstat (limited to 'testing/cherrytree')
-rw-r--r--testing/cherrytree/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/cherrytree/APKBUILD b/testing/cherrytree/APKBUILD
new file mode 100644
index 0000000000..1507efd44c
--- /dev/null
+++ b/testing/cherrytree/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Paul Bredbury <brebs@sent.com>
+pkgname=cherrytree
+pkgver=0.38.7
+pkgrel=0
+pkgdesc="Hierarchical note-taking app featuring rich text"
+url="https://www.giuspen.com/cherrytree/"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="py-dbus py-gtk py-pygtksourceview2"
+makedepends="gettext"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://www.giuspen.com/software/$pkgname-$pkgver.tar.xz"
+options="!check" # No test suite
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ # Run by desktop-file-utils.trigger instead
+ sed -e "/subprocess.*update-desktop-database/d" -i setup.py
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3b52b0a5f1bc7d2aa5eb7622c31ded85f7cf1c0361f9bfa1842c7a07f8f3fb694b27f8d6fe8486482bf293b0300a383cf02ba2dc79d520a1862ae439a17cc371 cherrytree-0.38.7.tar.xz"