aboutsummaryrefslogtreecommitdiffstats
path: root/testing/choqok
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-06 12:59:34 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-06 11:24:25 -0300
commit29a6d54e9741210a14d66703f60238fb3f6f6e07 (patch)
treeb39eaa1aadb2c1060e1f32e941134b1bf6b1697a /testing/choqok
parent776b9cf5f7009c7f782f3476734f1a9b0e86d0f0 (diff)
downloadaports-29a6d54e9741210a14d66703f60238fb3f6f6e07.tar.bz2
aports-29a6d54e9741210a14d66703f60238fb3f6f6e07.tar.xz
testing/choqok: new aport
Diffstat (limited to 'testing/choqok')
-rw-r--r--testing/choqok/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/choqok/APKBUILD b/testing/choqok/APKBUILD
new file mode 100644
index 0000000000..a7ed19b3f9
--- /dev/null
+++ b/testing/choqok/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=choqok
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="A micro-blogging client"
+url="https://choqok.kde.org/"
+arch="all"
+license="GPL-2.0-only OR GPL-3.0-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtnetworkauth-dev
+ kconfigwidgets-dev kcoreaddons-dev kdoctools-dev ki18n-dev kemoticons-dev
+ kglobalaccel-dev kguiaddons-dev kcmutils-dev kio-dev knotifications-dev
+ knotifyconfig-dev sonnet-dev ktextwidgets-dev kwallet-dev kwidgetsaddons-dev
+ kxmlgui-dev purpose-dev qca-dev kparts-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/choqok/${pkgver%.*}/src/choqok-$pkgver.tar.xz"
+
+build() {
+ cmake -B "$builddir"/build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make -C build
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C build install
+}
+
+sha512sums="6f5998078e555f7b4a40270ad0a4defa2d15bb8440b810320fc4cfc38d78cb34bb9b2f6a38eb33eb3217b51a78a7fbc7f79224cd0ddb0fcbf8c9035d8e600e96 choqok-1.7.0.tar.xz"